summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-07-02 12:22:53 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-07-02 12:22:53 -0700
commit8efdd74ac4ff2008f3f7e67be92a892ebe31c00c (patch)
treecd972314d2a00e838af92269dba19511358df044
parentsys-fs/zfs: add 2.1.0, drop 2.1.0_rc8 (diff)
downloadgentoo-8efdd74a.tar.gz
gentoo-8efdd74a.tar.bz2
gentoo-8efdd74a.zip
sys-fs/zfs-kmod: adjust postinst phase
remove old migration code, it was needed for migration from 0.6x versions. make grub section conditional and mention new compat filag zpool create -o compatibility=grub2 ... https://github.com/openzfs/zfs/pull/11468 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--sys-fs/zfs-kmod/zfs-kmod-2.1.0.ebuild40
1 files changed, 13 insertions, 27 deletions
diff --git a/sys-fs/zfs-kmod/zfs-kmod-2.1.0.ebuild b/sys-fs/zfs-kmod/zfs-kmod-2.1.0.ebuild
index 9306651ee82f..1bb0a99b0c65 100644
--- a/sys-fs/zfs-kmod/zfs-kmod-2.1.0.ebuild
+++ b/sys-fs/zfs-kmod/zfs-kmod-2.1.0.ebuild
@@ -165,15 +165,6 @@ src_install() {
pkg_postinst() {
linux-mod_pkg_postinst
- # Remove old modules
- if [[ -d "${EROOT}/lib/modules/${KV_FULL}/addon/zfs" ]]; then
- ewarn "${PN} now installs modules in ${EROOT}/lib/modules/${KV_FULL}/extra/zfs"
- ewarn "Old modules were detected in ${EROOT}/lib/modules/${KV_FULL}/addon/zfs"
- ewarn "Automatically removing old modules to avoid problems."
- rm -r "${EROOT}/lib/modules/${KV_FULL}/addon/zfs" || die "Cannot remove modules"
- rmdir --ignore-fail-on-non-empty "${EROOT}/lib/modules/${KV_FULL}/addon"
- fi
-
if [[ -z ${ROOT} ]] && use dist-kernel; then
set_arch_to_portage
dist-kernel_reinstall_initramfs "${KV_DIR}" "${KV_FULL}"
@@ -184,22 +175,17 @@ pkg_postinst() {
ewarn "at least 256M and decreasing zfs_arc_max to some value less than that."
fi
- ewarn "This version of OpenZFS includes support for new feature flags"
- ewarn "that are incompatible with previous versions. GRUB2 support for"
- ewarn "/boot with the new feature flags is not yet available."
- ewarn "Do *NOT* upgrade root pools to use the new feature flags."
- ewarn "Any new pools will be created with the new feature flags by default"
- ewarn "and will not be compatible with older versions of ZFSOnLinux. To"
- ewarn "create a newpool that is backward compatible wih GRUB2, use "
- ewarn
- ewarn "zpool create -d -o feature@async_destroy=enabled "
- ewarn " -o feature@empty_bpobj=enabled -o feature@lz4_compress=enabled"
- ewarn " -o feature@spacemap_histogram=enabled"
- ewarn " -o feature@enabled_txg=enabled "
- ewarn " -o feature@extensible_dataset=enabled -o feature@bookmarks=enabled"
- ewarn " ..."
- ewarn
- ewarn "GRUB2 support will be updated as soon as either the GRUB2"
- ewarn "developers do a tag or the Gentoo developers find time to backport"
- ewarn "support from GRUB2 HEAD."
+ if has_version sys-boot/grub; then
+ ewarn "This version of OpenZFS includes support for new feature flags"
+ ewarn "that are incompatible with previous versions. GRUB2 support for"
+ ewarn "/boot with the new feature flags is not yet available."
+ ewarn "Do *NOT* upgrade root pools to use the new feature flags."
+ ewarn "Any new pools will be created with the new feature flags by default"
+ ewarn "and will not be compatible with older versions of ZFSOnLinux. To"
+ ewarn "create a newpool that is backward compatible wih GRUB2, use "
+ ewarn
+ ewarn "zpool create -o compatibility=grub2 ..."
+ ewarn
+ ewarn "Refer to /etc/zfs/compatibility.d/grub2 for list of features."
+ fi
}