summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-05-31 05:36:56 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-05-31 05:48:10 -0400
commit8f0d3c2067afb9f443ec2dad61f28401d31365f2 (patch)
tree3d7904a7667efda96e194f6bce47b8735c1532a6
parentdev-libs/libxslt: enable py3.11 (diff)
downloadgentoo-8f0d3c20.tar.gz
gentoo-8f0d3c20.tar.bz2
gentoo-8f0d3c20.zip
dev-python/pycuda: add 2021.1, enable py3.10
Also: - use pep517=setuptools - depend on nvidia-cuda-toolkit[profiler] wrt bug #748537 - drop two no-op sed expressions (was no-op in previous version too) - only restrict userpriv when running tests - EPREFIX->ESYSROOT, these paths aren't stored as far as I can see - update LICENSE, did not see any reference to GPL-2 - misc cleanups Unsure if entirely setup right as I don't use this nor dug deep, and two failing tests on my hardware (with any python version) and couldn't get the old version's test suite to run right to compare (90% failures). Closes: https://bugs.gentoo.org/748537 Closes: https://bugs.gentoo.org/845795 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--dev-python/pycuda/Manifest1
-rw-r--r--dev-python/pycuda/pycuda-2021.1.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/dev-python/pycuda/Manifest b/dev-python/pycuda/Manifest
index 43b7de5f8e50..10348ce0b78a 100644
--- a/dev-python/pycuda/Manifest
+++ b/dev-python/pycuda/Manifest
@@ -1 +1,2 @@
DIST pycuda-2019.1.2.tar.gz 1584807 BLAKE2B 3250430ad626b28242ff44ab9576cf1f5ecf77530e789470dfebab324de95a735c0f56e67134891bace44b1f9b7a25133ffcb74c652c6568c5afedce26907fdb SHA512 22829daa5923342eec400a24342b1d738226073bb676476e4af97629d9311426b5d2465e60811696e55401568b90e152ac96d877c6262c416099a609862db742
+DIST pycuda-2021.1.tar.gz 1682423 BLAKE2B 0ebd7554a5f92cd0d39ce7b5f64218f0b0dcfa1f3e63d3180306a149ad0581150630813eee7fbc17e32bb35ea711a46b84332705d6ffece7b11e7e928ef07aad SHA512 1df09f59e254f7e39b630ff41d22237ab0c81c0e6e7b7611c57eb98ade8531356b9cb3e381e6fa7e8495a46c465458febaf8ad56ceb8d570b5b25defb6dd55a9
diff --git a/dev-python/pycuda/pycuda-2021.1.ebuild b/dev-python/pycuda/pycuda-2021.1.ebuild
new file mode 100644
index 000000000000..ffc9b069deb9
--- /dev/null
+++ b/dev-python/pycuda/pycuda-2021.1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit cuda distutils-r1
+
+DESCRIPTION="Python wrapper for NVIDIA CUDA"
+HOMEPAGE="https://mathema.tician.de/software/pycuda/ https://pypi.org/project/pycuda/"
+SRC_URI="mirror://pypi/${P::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples opengl test"
+
+RDEPEND="
+ dev-libs/boost:=[python,${PYTHON_USEDEP}]
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytools[${PYTHON_USEDEP}]
+ dev-util/nvidia-cuda-toolkit[profiler]
+ x11-drivers/nvidia-drivers
+ opengl? ( virtual/opengl )"
+DEPEND="${RDEPEND}"
+
+# We need write acccess /dev/nvidia0 and /dev/nvidiactl and the portage
+# user is (usually) not in the video group
+RESTRICT="test? ( userpriv ) !test? ( test )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ cuda_sanitize
+
+ sed "s|\"--preprocess\"|&,\"--compiler-bindir=$(cuda_gccdir)\"|" \
+ -i pycuda/compiler.py || die
+
+ > siteconf.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_configure() {
+ mkdir -p "${BUILD_DIR}" || die
+ cd "${BUILD_DIR}" || die
+
+ local conf=(
+ "${EPYTHON}" "${S}"/configure.py
+ --boost-inc-dir="${ESYSROOT}"/usr/include
+ --boost-lib-dir="${ESYSROOT}"/usr/$(get_libdir)
+ --boost-python-libname=boost_${EPYTHON/./}.so
+ --boost-thread-libname=boost_thread
+ --cuda-inc-dir="${ESYSROOT}"/opt/cuda/include
+ --cuda-root="${ESYSROOT}"/opt/cuda
+ --cudadrv-lib-dir="${ESYSROOT}"/usr/$(get_libdir)
+ --cudart-lib-dir="${ESYSROOT}"/opt/cuda/$(get_libdir)
+ --no-use-shipped-boost
+ $(usev opengl --cuda-enable-gl)
+ )
+ echo ${conf[*]}
+ "${conf[@]}" || die
+}
+
+python_test() {
+ # we need write access to this to run the tests
+ addwrite /dev/nvidia0
+ addwrite /dev/nvidiactl
+ addwrite /dev/nvidia-uvm
+ addwrite /dev/nvidia-uvm-tools
+
+ EPYTEST_DESELECT=(
+ # needs investigation, perhaps failure is hardware-specific
+ test/test_driver.py::test_pass_cai_array
+ test/test_driver.py::test_pointer_holder_base
+ )
+
+ cd "${T}" || die
+ epytest "${S}"/test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}