summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-05-05 12:01:00 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-05-05 13:15:50 -0700
commit8f27765e9ff9d047bd9697191ded79e66fada809 (patch)
tree4aee7375eeafab4af238365fee5b16b8fc89e9fd
parentdev-lang/rust: greatly reduce documentation installation time (diff)
downloadgentoo-8f27765e.tar.gz
gentoo-8f27765e.tar.bz2
gentoo-8f27765e.zip
dev-lang/rust: dump RUSTFLAGS* into build log
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--dev-lang/rust/rust-1.51.0-r2.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-lang/rust/rust-1.51.0-r2.ebuild b/dev-lang/rust/rust-1.51.0-r2.ebuild
index 17e948f58412..926ebd4628c4 100644
--- a/dev-lang/rust/rust-1.51.0-r2.ebuild
+++ b/dev-lang/rust/rust-1.51.0-r2.ebuild
@@ -469,8 +469,15 @@ src_configure() {
done
fi # I_KNOW_WHAT_I_AM_DOING_CROSS
- einfo "Rust configured with the following settings:"
+ einfo "Rust configured with the following flags:"
+
+ echo "RUSTFLAGS=\"${RUSTFLAGS:-}\""
+ echo "RUSTFLAGS_BOOTSTRAP=\"${RUSTFLAGS_BOOTSTRAP:-}\""
+ echo "RUSTFLAGS_NOT_BOOTSTRAP=\"${RUSTFLAGS_NOT_BOOTSTRAP:-}\""
+ echo
+ einfo "config.toml contents:"
cat "${S}"/config.toml || die
+ echo
}
src_compile() {