summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-09-04 19:34:14 +0200
committerDavid Seifert <soap@gentoo.org>2021-09-04 19:34:14 +0200
commit8f2d218d0b0e6d082b5d87169933e1f396d89443 (patch)
tree0dd515ca4eec1c0e9c66c0af3690f5927ac76ab5
parentsys-block/open-isns: drop 0.98 (diff)
downloadgentoo-8f2d218d0b0e6d082b5d87169933e1f396d89443.tar.gz
gentoo-8f2d218d0b0e6d082b5d87169933e1f396d89443.tar.bz2
gentoo-8f2d218d0b0e6d082b5d87169933e1f396d89443.zip
sys-block/open-iscsi: drop 2.1.3
Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--sys-block/open-iscsi/Manifest1
-rw-r--r--sys-block/open-iscsi/open-iscsi-2.1.3.ebuild139
2 files changed, 0 insertions, 140 deletions
diff --git a/sys-block/open-iscsi/Manifest b/sys-block/open-iscsi/Manifest
index b7cd9738e2eb..27e0fa000d2b 100644
--- a/sys-block/open-iscsi/Manifest
+++ b/sys-block/open-iscsi/Manifest
@@ -1,2 +1 @@
-DIST open-iscsi-2.1.3.tar.gz 619746 BLAKE2B 884e24ae6e16578f3cbd8ccea2557e820d4bf4d20c7f88890100ca93f48df88dc7284cc4eca19d93187516fd21a2c5b71eb53f0d8fe395d2ce42fd202dc355d6 SHA512 0de417dc45b765458c5a1f09029b5df9b5c18d45d7a8fb6b38d539b7013f512a3c8731d5046f554611eccc77b93fea0df30fe4932d79cea44776ac944c398a52
DIST open-iscsi-2.1.4.tar.gz 621247 BLAKE2B 043a999b2f397a6c740d61654079d7ab966caee6cf6cfb244ddd70eae4f5201045b371ce5fbe244216a2a210a5379c92e8c3fbe62d33707cf05e7a4a20a13a91 SHA512 ae0663a964d86e6a4c19203598b859173c93ecce550f9bc9855ff735dd51a3c45822f2bc1cc99e6891c56ef1d16c42223803f07a961558fe6e38ead2164faef3
diff --git a/sys-block/open-iscsi/open-iscsi-2.1.3.ebuild b/sys-block/open-iscsi/open-iscsi-2.1.3.ebuild
deleted file mode 100644
index 2d727f8645e7..000000000000
--- a/sys-block/open-iscsi/open-iscsi-2.1.3.ebuild
+++ /dev/null
@@ -1,139 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools linux-info flag-o-matic toolchain-funcs udev systemd
-
-DESCRIPTION="A performant, transport independent, multi-platform implementation of RFC3720"
-HOMEPAGE="http://www.open-iscsi.com/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0/0.2"
-KEYWORDS="~alpha amd64 arm arm64 ~ia64 ~mips ppc ppc64 sparc x86"
-IUSE="debug infiniband +tcp rdma systemd"
-
-DEPEND="
- sys-apps/kmod
- sys-block/open-isns:=
- sys-kernel/linux-headers
- infiniband? ( sys-fabric/ofed )
- dev-libs/openssl:0=
- systemd? ( sys-apps/systemd )
-"
-RDEPEND="${DEPEND}
- sys-fs/lsscsi
- sys-apps/util-linux"
-BDEPEND="virtual/pkgconfig"
-
-REQUIRED_USE="infiniband? ( rdma ) || ( rdma tcp )"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.1.1-Makefiles.patch"
-)
-
-pkg_setup() {
- linux-info_pkg_setup
-
- if kernel_is -lt 2 6 16; then
- die "Sorry, your kernel must be 2.6.16-rc5 or newer!"
- fi
-
- # Needs to be done, as iscsid currently only starts, when having the iSCSI
- # support loaded as module. Kernel builtin options don't work. See this for
- # more information:
- # https://groups.google.com/group/open-iscsi/browse_thread/thread/cc10498655b40507/fd6a4ba0c8e91966
- # If there's a new release, check whether this is still valid!
- TCP_MODULES="SCSI_ISCSI_ATTRS ISCSI_TCP"
- RDMA_MODULES="INFINIBAND_ISER"
- INFINIBAND_MODULES="INFINIBAND_IPOIB INIBAND_USER_MAD INFINIBAND_USER_ACCESS"
- CONFIG_CHECK_MODULES="tcp? ( ${TCP_MODULES} ) rdma? ( ${RDMA_MODULES} ) infiniband? ( ${INFINIBAND_MODULES} )"
- if linux_config_exists; then
- if use tcp; then
- for module in ${TCP_MODULES}; do
- linux_chkconfig_module ${module} || ewarn "${module} needs to be built as module (builtin doesn't work)"
- done
- fi
- if use infiniband; then
- for module in ${INFINIBAND_MODULES}; do
- linux_chkconfig_module ${module} || ewarn "${module} needs to be built as module (builtin doesn't work)"
- done
- fi
- if use rdma; then
- for module in ${RDMA_MODULES}; do
- linux_chkconfig_module ${module} || ewarn "${module} needs to be built as module (builtin doesn't work)"$
- done
- fi
- fi
-}
-
-src_prepare() {
- sed -e 's:^\(iscsid.startup\)\s*=.*:\1 = /usr/sbin/iscsid:' \
- -i etc/iscsid.conf || die
- sed -e 's@\(/sbin/\)@/usr\1@' \
- -i etc/systemd/iscsi* || die
- default
-
- pushd iscsiuio >/dev/null || die
- eautoreconf
- popd >/dev/null || die
-}
-
-src_configure() {
- use debug && append-cppflags -DDEBUG_TCP -DDEBUG_SCSI
- append-lfs-flags
-}
-
-src_compile() {
- # Stuffing CPPFLAGS into CFLAGS isn't entirely correct, but the build
- # is messed up already here, so it's not making it that much worse.
- KSRC="${KV_DIR}" CFLAGS="" \
- emake \
- OPTFLAGS="${CFLAGS} ${CPPFLAGS} $(usex systemd '' -DNO_SYSTEMD)" \
- AR="$(tc-getAR)" CC="$(tc-getCC)" \
- $(usex systemd '' NO_SYSTEMD=1) \
- user
-}
-
-src_install() {
- emake DESTDIR="${ED}" sbindir="/usr/sbin" install
- # Upstream make is not deterministic, per bug #601514
- rm -f "${ED}"/etc/initiatorname.iscsi
-
- dodoc README THANKS
-
- docinto test/
- dodoc $(find test -maxdepth 1 -type f ! -name ".*")
-
- insinto /etc/iscsi
- newins "${FILESDIR}"/initiatorname.iscsi initiatorname.iscsi.example
-
- newconfd "${FILESDIR}"/iscsid-conf.d iscsid
- newinitd "${FILESDIR}"/iscsid-init.d iscsid
-
- local unit
- local units=(
- iscsi.service
- iscsid.{service,socket}
- iscsiuio.{service,socket}
- )
- for unit in ${units[@]} ; do
- systemd_dounit etc/systemd/${unit}
- done
-
- keepdir /var/db/iscsi
- fperms 700 /var/db/iscsi
- fperms 600 /etc/iscsi/iscsid.conf
-}
-
-pkg_postinst() {
- in='/etc/iscsi/initiatorname.iscsi'
- if [[ ! -f "${EROOT}${in}" ]] && [[ -f "${EROOT}${in}.example" ]] ; then
- {
- cat "${EROOT}${in}.example"
- echo "# InitiatorName generated by ${CATEGORY}/${PF} at $(date -uR)"
- echo "InitiatorName=$(${ROOT}/usr/sbin/iscsi-iname)"
- } >> "${EROOT}${in}.tmp" && mv -f "${EROOT}${in}.tmp" "${EROOT}${in}"
- fi
-}