summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-02 16:14:51 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-02 16:43:08 +0300
commit8f3214822462988a2ec5bd8cf80e4f8cac3c7423 (patch)
tree27a6756635c94e067c93a79db774eb5b0bd5800e
parentprofiles: last rite mail-filter/sigh (diff)
downloadgentoo-8f321482.tar.gz
gentoo-8f321482.tar.bz2
gentoo-8f321482.zip
dev-python/etuples: add 0.3.6
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/etuples/Manifest1
-rw-r--r--dev-python/etuples/etuples-0.3.6.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/etuples/Manifest b/dev-python/etuples/Manifest
index be8b750c0b5c..b58f04f56ce0 100644
--- a/dev-python/etuples/Manifest
+++ b/dev-python/etuples/Manifest
@@ -1 +1,2 @@
DIST etuples-0.3.5.gh.tar.gz 44924 BLAKE2B 81b603c851b89b3ec3556246d7dfc12a533632f4e99f8b784c4b9f46c3ee51fe7d370556e376a957e52c980b6e16fc93d85c597d31cee371fa2e5cbeec962c9e SHA512 df51ff42609a341c42009b650dadac2a6fb8ea85c3ccc6145ee2bdf6270ed9509d73196f8b0b789091918e93492f766d5fc242e2d5acc30074c171a2334a42fa
+DIST etuples-0.3.6.gh.tar.gz 45115 BLAKE2B 5fc88a46433d8074e019f97de1845732ce088e08098f8fd72b9ad0af2d869420805f753cd4a70c24f309d37115a36d9a634c8d3a1837506f781e4b6771e8cee8 SHA512 285d56c291f765c5364a53c7746bdab8aaad71bdc40607f10f0fb9570f22c66352737ba0543d447d83ecc60f7cdfd4e7b406efea7ff9b15d72818f31a10ba4e9
diff --git a/dev-python/etuples/etuples-0.3.6.ebuild b/dev-python/etuples/etuples-0.3.6.ebuild
new file mode 100644
index 000000000000..5d23977f1232
--- /dev/null
+++ b/dev-python/etuples/etuples-0.3.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python S-expression emulation using tuple-like objects"
+HOMEPAGE="
+ https://pypi.org/project/etuples/
+ https://github.com/pythological/etuples/
+"
+SRC_URI="
+ https://github.com/pythological/etuples/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cons[${PYTHON_USEDEP}]
+ dev-python/multipledispatch[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest