summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2019-02-18 00:02:03 +0800
committerJason Zaman <perfinion@gentoo.org>2019-02-18 20:51:59 +0800
commit8f326e82398b7fec815f7c3f5cefec7a4c927afc (patch)
tree6793f17e738a000a1facde328796d09eef571a99
parentsci-chemistry/gromacs: Version bump (diff)
downloadgentoo-8f326e82398b7fec815f7c3f5cefec7a4c927afc.tar.gz
gentoo-8f326e82398b7fec815f7c3f5cefec7a4c927afc.tar.bz2
gentoo-8f326e82398b7fec815f7c3f5cefec7a4c927afc.zip
dev-python/absl-py: bump 0.7.0
Signed-off-by: Jason Zaman <perfinion@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--dev-python/absl-py/Manifest1
-rw-r--r--dev-python/absl-py/absl-py-0.7.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/absl-py/Manifest b/dev-python/absl-py/Manifest
index 6c9ddc20f1b5..1749363c1cc3 100644
--- a/dev-python/absl-py/Manifest
+++ b/dev-python/absl-py/Manifest
@@ -1 +1,2 @@
DIST absl-py-0.2.2.tar.gz 189357 BLAKE2B b53976b50f1738d671a32df2fabf197785cb4be1f68dbf7f0bdd5bbbb1a73439646f5b6a9ea42d5df40debdbb8e8c72c554f428a948f3117dba5d6a8e2b473f2 SHA512 d2a393e78acc9ac28fc9b1129c23de9c2ab6059a7527eaa29e4182356b16cbce1fede94af2a8b51af9d1c606b162d8ae84eb3036ced784a89d4f7547bfce73ed
+DIST absl-py-0.7.0.tar.gz 213291 BLAKE2B 9a8575f1c6d0c98d750cf0fc5bc528778b0498beb67291368ddf210131ea32073228fe5b354be92bbfac2e36ede1638006d65b5517917b6453e2e599110699d3 SHA512 032201603aa0757e70cd35dc2eb1c4f7ef668060f42a5e22223e7102b2abf8d5e9e08c883deaa7bce822712245b040aaf99abf94a8cd5bd9688937fbad982586
diff --git a/dev-python/absl-py/absl-py-0.7.0.ebuild b/dev-python/absl-py/absl-py-0.7.0.ebuild
new file mode 100644
index 000000000000..27a30fd06963
--- /dev/null
+++ b/dev-python/absl-py/absl-py-0.7.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Abseil Python Common Libraries"
+HOMEPAGE="https://github.com/abseil/abseil-py"
+SRC_URI="https://github.com/abseil/abseil-py/archive/pypi-v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/abseil-py-pypi-v${PV}"