summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2020-04-27 21:50:24 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-21 01:28:30 +0200
commit8f3cad7da7f49d693229770f014432f2894c58c8 (patch)
tree860cab9e0fd3261484ad6dc5a3df4f667cf99d07
parentlxqt-base/lxqt-openssh-askpass: add version 0.15.0 (diff)
downloadgentoo-8f3cad7da7f49d693229770f014432f2894c58c8.tar.gz
gentoo-8f3cad7da7f49d693229770f014432f2894c58c8.tar.bz2
gentoo-8f3cad7da7f49d693229770f014432f2894c58c8.zip
lxqt-base/lxqt-policykit: add version 0.15.0
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--lxqt-base/lxqt-policykit/Manifest1
-rw-r--r--lxqt-base/lxqt-policykit/lxqt-policykit-0.15.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-policykit/Manifest b/lxqt-base/lxqt-policykit/Manifest
index 8e21268f1764..2838be29df71 100644
--- a/lxqt-base/lxqt-policykit/Manifest
+++ b/lxqt-base/lxqt-policykit/Manifest
@@ -1 +1,2 @@
DIST lxqt-policykit-0.14.1.tar.xz 37616 BLAKE2B 05175f99bd63fae795499eff02b224a589842e6f4ce0faa66dcb949d99625d8fcdd54600d80832b5211e297e9c0da3aa33ecd6e47b5dd7b0e544a1d301e4e483 SHA512 c3df41a45ef4d04eba9ce0c9f29d4c9b68a192302e85e192a26ae73617b87d0ad70ec64135f500485d4c10095754e36935bf9790ffd83d0197b1bb784971a940
+DIST lxqt-policykit-0.15.0.tar.xz 37712 BLAKE2B b9263234766dd9a2e89288f6668e8553e1f5deae0e306443fc3d15268f3fbbb4b9cfb81987d1e1f9c96ece4494ef700a6e40bf5e498eeb3d7377f3848d09b376 SHA512 2dbbe6d626ef5da816f080354caf564a1aa58270ae299483b9a4ce35d5f1bdb3c652dcb5f12d2668a0ea82556414b00320d2bd88fcadb37fbbdbf724a17e3c41
diff --git a/lxqt-base/lxqt-policykit/lxqt-policykit-0.15.0.ebuild b/lxqt-base/lxqt-policykit/lxqt-policykit-0.15.0.ebuild
new file mode 100644
index 000000000000..daf686ddd39c
--- /dev/null
+++ b/lxqt-base/lxqt-policykit/lxqt-policykit-0.15.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="LXQt PolKit authentication agent"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.7.0
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/glib:2
+ >=dev-libs/libqtxdg-3.3.1
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ =lxqt-base/liblxqt-$(ver_cut 1-2)*
+ sys-auth/polkit-qt[qt5(+)]
+"
+RDEPEND="${DEPEND}
+ !lxqt-base/lxqt-l10n
+"
+
+src_install() {
+ cmake_src_install
+ doman man/*.1
+}