summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-05-02 13:15:02 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-05-02 13:18:11 -0500
commit8f442abe3fceb6fe23b7198bb0f9f5ad274543c5 (patch)
treee48ce70e6453277d2d5addc9d8060f56bf2a3e59
parentapp-admin/puppetserver: 6.11.0 bump (diff)
downloadgentoo-8f442abe.tar.gz
gentoo-8f442abe.tar.bz2
gentoo-8f442abe.zip
app-admin/puppet-agent: 6.15.0 bump
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--app-admin/puppet-agent/Manifest2
-rw-r--r--app-admin/puppet-agent/puppet-agent-6.15.0.ebuild75
2 files changed, 77 insertions, 0 deletions
diff --git a/app-admin/puppet-agent/Manifest b/app-admin/puppet-agent/Manifest
index 9d68ed7de9d0..918477a61af5 100644
--- a/app-admin/puppet-agent/Manifest
+++ b/app-admin/puppet-agent/Manifest
@@ -1,2 +1,4 @@
DIST puppet-agent_6.14.0-1stretch_amd64.deb 22450130 BLAKE2B fe6e30d99357328a884944e59d7cb1c66ad9fc36642ba377ed99e23551c5cbf06cffc4336b47440389fee7a9f1996b8325d18335768187f5d052fcecae041f5b SHA512 41d87f1ab4ead019eb5ef90ad21e557db686729151618e4ec642ea6636feda383874f7d457de7e9e323cf44d9d410e7fb650edd6e69b186c2fdff5657955ac5a
DIST puppet-agent_6.14.0-1stretch_i386.deb 22792198 BLAKE2B 7638fd1edfeb22377ab22484dd0fd5377bab6ee5e3e01c64ffd8eae29b08e0182204446db23d8cf68018a58c2419ce22c4dda4fd10a6dfac64356d68a5478bfa SHA512 dc787dfeb2565fde00da6e991fb94435c56e804657a38268ad49d72783b9857de4e359d6d9002525759684ddcb48a00e2fdb73f069cd79da74237bcb9530a116
+DIST puppet-agent_6.15.0-1stretch_amd64.deb 22581842 BLAKE2B 19c45427e56a41f6030836129a7fb2824ea47f1000745a8c74b0968c61f719d3cef9a0e02f51009b8e91c4ad66445c074ccc203754bb13d82007316a3d053c60 SHA512 4ec7e04fb6bab697bfccd369740a57f735476a4614dbfa1f7c893901f5ffb9d6ce3d79886b6e035805b1a8f2c3de3e0b9b468b08909881df6022c9700c7a2768
+DIST puppet-agent_6.15.0-1stretch_i386.deb 22917002 BLAKE2B 5bab2b6cdde11a46e64996074e8db50d48d004b601c0d08ddfde9c8dec0c0f62da1176b9148d084f0250b582460606b7cd0a97291d157a186b7a97dee4184c51 SHA512 89e676491f7b7b44c9c747b129166db7b025adf76d9911d12d7d026aa8d04de293d3d1c638ca309ee8ed45a37c49b4ab0076ea0c711ac0e43f4297084446784f
diff --git a/app-admin/puppet-agent/puppet-agent-6.15.0.ebuild b/app-admin/puppet-agent/puppet-agent-6.15.0.ebuild
new file mode 100644
index 000000000000..6ef508024129
--- /dev/null
+++ b/app-admin/puppet-agent/puppet-agent-6.15.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit eutils systemd unpacker
+
+DESCRIPTION="general puppet client utils along with hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_BASE="http://apt.puppetlabs.com/pool/stretch/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1stretch"
+SRC_URI="
+ amd64? ( ${SRC_BASE}_amd64.deb )
+ x86? ( ${SRC_BASE}_i386.deb )"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+CDEPEND="!app-admin/puppet
+ !dev-ruby/hiera
+ !dev-ruby/facter
+ !app-emulation/virt-what
+ acct-user/puppet
+ acct-group/puppet"
+
+DEPEND="
+ ${CDEPEND}
+ app-admin/augeas"
+RDEPEND="${CDEPEND}
+ app-portage/eix
+ sys-apps/dmidecode
+ sys-libs/libselinux
+ sys-libs/glibc
+ sys-libs/readline:0/7
+ sys-libs/ncurses:0[tinfo]
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ puppetdb? ( >=dev-ruby/puppetdb-termini-5.0.1 )"
+
+S=${WORKDIR}
+
+src_install() {
+ # conf.d
+ doconfd etc/default/puppet
+ doconfd etc/default/pxp-agent
+ # logrotate.d
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/pxp-agent
+ # puppet itself
+ insinto /etc/puppetlabs
+ doins -r etc/puppetlabs/*
+ # logdir for systemd
+ dodir var/log/puppetlabs/puppet/
+ fperms 0750 var/log/puppetlabs/puppet/
+ # the rest
+ insinto /opt
+ dodir opt/puppetlabs/puppet/cache
+ doins -r opt/*
+ fperms 0750 /opt/puppetlabs/puppet/cache
+ # init
+ newinitd "${FILESDIR}/puppet.initd" puppet
+ systemd_dounit lib/systemd/system/puppet.service
+ systemd_dounit lib/systemd/system/pxp-agent.service
+ systemd_newtmpfilesd "${FILESDIR}/puppet-agent.conf.tmpfilesd" puppet-agent.conf
+ # symlinks
+ chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+ chmod 0755 "${D}//opt/puppetlabs/puppet/lib/virt-what/virt-what-cpuid-helper"
+ dosym ../../opt/puppetlabs/bin/facter /usr/bin/facter
+ dosym ../../opt/puppetlabs/bin/hiera /usr/bin/hiera
+ dosym ../../opt/puppetlabs/bin/puppet /usr/bin/puppet
+ dosym ../../opt/puppetlabs/puppet/bin/virt-what /usr/bin/virt-what
+}