summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-02-27 23:14:10 -0800
committerMatt Turner <mattst88@gentoo.org>2019-02-27 23:14:16 -0800
commit8f4ae4debf9fcd3e3e9c3fb86909931661388165 (patch)
tree5df20fcb2c7c97c28c3bee38d0bc7ea91cb726a9
parentx11-libs/libfontenc: Version bump to 1.1.4 (diff)
downloadgentoo-8f4ae4debf9fcd3e3e9c3fb86909931661388165.tar.gz
gentoo-8f4ae4debf9fcd3e3e9c3fb86909931661388165.tar.bz2
gentoo-8f4ae4debf9fcd3e3e9c3fb86909931661388165.zip
x11-libs/libxkbcommon: Version bump to 0.8.4
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-libs/libxkbcommon/Manifest1
-rw-r--r--x11-libs/libxkbcommon/libxkbcommon-0.8.4.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/x11-libs/libxkbcommon/Manifest b/x11-libs/libxkbcommon/Manifest
index c7b80aa58636..4cf42720b709 100644
--- a/x11-libs/libxkbcommon/Manifest
+++ b/x11-libs/libxkbcommon/Manifest
@@ -1,2 +1,3 @@
DIST libxkbcommon-0.8.2.tar.xz 644040 BLAKE2B c323384308d9730924d6f1cb7ad55fdb3d1a37289f648b981c54dc5997c67c857d33f8ad872fc7646b462ebc97252dca30efe2a2e12d1f1f08a8a1604a5de23f SHA512 b714240ec6120bbe44b5da7a4f89b1c2f24cfd6e5ebbe81e5290d135c8f2e5a68f89ac256b73430a446167345f8db309b35dcf74f3d3840e20897cd91eccc172
DIST libxkbcommon-0.8.3.tar.xz 646124 BLAKE2B c80d5065395ee8adec436243cf42fa82a05a5797be711b4e10d70d92ef742c707f034adf870480e1797e1b05135b5ce644e6ebefd036aaac7d3fb7435b5bd543 SHA512 0a3dfacc17eddfc10fe3edb946bede5070f2744effe642bd96076996f262a41addb691d62c0d738457da522d1fea02c297c9a2a8b1f56521adbf50ca917577c2
+DIST libxkbcommon-0.8.4.tar.xz 648592 BLAKE2B 6205ca08f1ccb6d85320428317e9d023e2f2a56dcaa77e34a9f9ea42bbf67c9ee27a3123dd8e880ead3fa92c4cd7718bde55a255c52f16fef8d33c395c2511a9 SHA512 dbd441d0d7d5ba4fb352d64d150d163d4cdcf8340059457c291dc1fc69d1606ff6589732cb41a7fcfe106af0192977b243d7d68c4d95b90ece7abb620df360e3
diff --git a/x11-libs/libxkbcommon/libxkbcommon-0.8.4.ebuild b/x11-libs/libxkbcommon/libxkbcommon-0.8.4.ebuild
new file mode 100644
index 000000000000..b5f670fbec00
--- /dev/null
+++ b/x11-libs/libxkbcommon/libxkbcommon-0.8.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+XORG_MULTILIB="yes"
+
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EXPERIMENTAL="true"
+ EGIT_REPO_URI="https://github.com/xkbcommon/${PN}"
+else
+ XORG_BASE_INDIVIDUAL_URI=""
+ SRC_URI="https://xkbcommon.org/download/${P}.tar.xz"
+fi
+
+inherit xorg-3 ${GIT_ECLASS}
+
+DESCRIPTION="X.Org xkbcommon library"
+HOMEPAGE="https://xkbcommon.org/"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd"
+IUSE="X doc test"
+
+BDEPEND="
+ sys-devel/bison
+ X? ( x11-base/xorg-proto )
+ doc? ( app-doc/doxygen )"
+DEPEND="X? ( >=x11-libs/libxcb-1.10:=[${MULTILIB_USEDEP},xkb] )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ --with-xkb-config-root="${EPREFIX}/usr/share/X11/xkb"
+ $(use X || use_enable X x11)
+ $(use_with doc doxygen)
+ )
+}