summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2023-08-05 08:36:39 +0000
committerSam James <sam@gentoo.org>2023-08-07 06:42:22 +0100
commit8f4c2c794c4176671cec42f0e04a7c5890b10b31 (patch)
treefcc64a137c701fc825f0bbc0751729d20a03aab0
parentmail-filter/rspamd: sync live (diff)
downloadgentoo-8f4c2c79.tar.gz
gentoo-8f4c2c79.tar.bz2
gentoo-8f4c2c79.zip
media-libs/smpeg: Fix C++17 does not allow register storage class
Closes: https://bugs.gentoo.org/894568 Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32185 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-libs/smpeg/Manifest1
-rw-r--r--media-libs/smpeg/smpeg-0.4.4-r12.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/media-libs/smpeg/Manifest b/media-libs/smpeg/Manifest
index 04f66be4d745..b744a3d6c58f 100644
--- a/media-libs/smpeg/Manifest
+++ b/media-libs/smpeg/Manifest
@@ -1,2 +1,3 @@
DIST smpeg-0.4.4-gtkm4.patch.bz2 3894 BLAKE2B 0ea9258a057108a462d9c4b9d9bcb21cdff71714507a3d09538f56817b206ec54681b3d2546b64c07f239ea3381f3644d26234853a239a2fe49353ba1c9b2759 SHA512 30370e0edd41767ce260d10de515be0087f47b479ec0085ec186506c93be0b2a404c1bcb1626f9a6a1f575160d9c382708d2769dddfe6dca6236fe0eaa58602d
+DIST smpeg-0.4.4-patches.tar.xz 12892 BLAKE2B 346c3cf9fe62f29ce86b2b743a5cc6f54189330408b37966ff1c009687ee6e79594e018637dd80f90c34b31701d73129b3fe7c0b89913a1b280613b06cd01f19 SHA512 9840173f257e0bd0ef2ff98a9dac50b239f4ddd048abe1d317666660f1d5da867ce8d4cabc36a1c51f53909358b87661811af6ce665283cb091f3349a03787a8
DIST smpeg-0.4.4.tar.gz 315054 BLAKE2B 16a7b87a207874deaaad64b5233964d4b0e244d35cc475cf0ed37302529ca4eb044393777fc98c202b5965de420f75bc5fb398ecc3eb0f97992d90e365f8a039 SHA512 d566bb68b0caacecdf61cd766b26e003fd4e153c243d873f7aae33ab69919202bd121bb9c10f494bd9530267ddec2a9e018eb46ee8bb9d502a29cd2de2f1bbfb
diff --git a/media-libs/smpeg/smpeg-0.4.4-r12.ebuild b/media-libs/smpeg/smpeg-0.4.4-r12.ebuild
new file mode 100644
index 000000000000..ac6f3a978168
--- /dev/null
+++ b/media-libs/smpeg/smpeg-0.4.4-r12.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic multilib-minimal
+
+DESCRIPTION="SDL MPEG Player Library"
+HOMEPAGE="https://icculus.org/smpeg/"
+SRC_URI="
+ https://mirrors.dotsrc.org/lokigames/open-source/smpeg/${P}.tar.gz
+ https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/smpeg-0.4.4-patches.tar.xz
+"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="cpu_flags_x86_mmx opengl"
+
+RDEPEND="
+ media-libs/libsdl[opengl?,sound,video,${MULTILIB_USEDEP}]
+ opengl? (
+ virtual/glu[${MULTILIB_USEDEP}]
+ virtual/opengl[${MULTILIB_USEDEP}]
+ )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${WORKDIR}"/smpeg-0.4.4-patches
+)
+
+src_prepare() {
+ default
+
+ rm acinclude.m4 || die
+ AT_M4DIR="m4" eautoreconf
+}
+
+multilib_src_configure() {
+ [[ ${CHOST} == *-solaris* ]] && append-libs -lnsl -lsocket
+
+ local myeconfargs=(
+ --disable-gtk-player
+ --enable-debug # disabling this only passes extra optimizations
+ --without-x # does not actually use X, only causes a headers check
+ $(use_enable cpu_flags_x86_mmx mmx)
+ $(use_enable opengl opengl-player)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name '*.la' -delete || die
+}