summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-30 19:38:23 +0100
committerSam James <sam@gentoo.org>2021-06-30 19:38:23 +0100
commit8f5097052b88037481256e81774cdd00f1ec37e7 (patch)
tree0d795367caf71826cb57b0df345720bd0927e5ea
parentsys-boot/mokutil: add 0.3.0_p20170405 (fix versioning), add libcrypt dependency (diff)
downloadgentoo-8f5097052b88037481256e81774cdd00f1ec37e7.tar.gz
gentoo-8f5097052b88037481256e81774cdd00f1ec37e7.tar.bz2
gentoo-8f5097052b88037481256e81774cdd00f1ec37e7.zip
sys-boot/mokutil: add 0.5.0
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-boot/mokutil/Manifest1
-rw-r--r--sys-boot/mokutil/mokutil-0.5.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/sys-boot/mokutil/Manifest b/sys-boot/mokutil/Manifest
index 48a3308653a1..c1c7ed4b466f 100644
--- a/sys-boot/mokutil/Manifest
+++ b/sys-boot/mokutil/Manifest
@@ -1 +1,2 @@
DIST mokutil-0.3.0_p20170405.tar.gz 32590 BLAKE2B 867574b05a7a7c842869f75bd3b6a0cd0af083862ffc912b25b12fe6283946968ac6872b25a727d37185fb821871d5a2f958afddbb7e2bfefde854c6f434ab8f SHA512 ee64627089efe341bff466249a126dcdcc4a53878b17f651b17423650c3aea76d52dcae01ed689ba5bd317125dd9a669816563aa676d46d8ac36863f38f9ea16
+DIST mokutil-0.5.0.tar.gz 37181 BLAKE2B 6bd74e4ef2777afcd80cfe1d56dba7c861b9cb7bb957db19529dc36df7d6172c1d43870b80fbacd5f2bf20dbe9c8174be0d4cb5ce3638ce83a99795ae7627c4b SHA512 600c142fcc44e33efd307341b814018ef956668790b56d42a523140e81098746d14ae096fc6c93985b3c26bb414b8b6862f59312f2c4bd9d657a11e4becc6ea7
diff --git a/sys-boot/mokutil/mokutil-0.5.0.ebuild b/sys-boot/mokutil/mokutil-0.5.0.ebuild
new file mode 100644
index 000000000000..ac6d632668e2
--- /dev/null
+++ b/sys-boot/mokutil/mokutil-0.5.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="The utility to manipulate machines owner keys which managed in shim"
+HOMEPAGE="https://github.com/lcp/mokutil"
+SRC_URI="https://github.com/lcp/mokutil/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/openssl:=
+ sys-libs/efivar:=
+ virtual/libcrypt:="
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}