summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-06 05:11:35 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-06 07:02:09 +0100
commit8f5b349250b4968843cccd8f9606e7a221ecaf6e (patch)
tree822ef93b370ac17b7bb992399904bf7739d7328f
parentdev-libs/libclc: Add 16.0.0_pre20221205 snapshot (diff)
downloadgentoo-8f5b3492.tar.gz
gentoo-8f5b3492.tar.bz2
gentoo-8f5b3492.zip
dev-python/botocore: Bump to 1.29.23
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.29.23.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 224f2f055d10..9011c21c6347 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -4,4 +4,5 @@ DIST botocore-1.29.18.gh.tar.gz 10837962 BLAKE2B c1d32b31ba687427f6c88e53dd4908d
DIST botocore-1.29.20.gh.tar.gz 10956292 BLAKE2B 3453a1051056f8f6bc870c66b66d81b4f68dca97068ebb0beed286f3534798483254a0a3390e9b2ce07d25a01b35e81ceccc9c5f8cfd5bf18147931a9048e242 SHA512 c99e1cb4f0f55715d88ec8fe6602fef60254cacd9e2c1b309bfa1b8dfdc5c979c60f558b08f953afcc0985859091f4fad5c21e1906c177eaa8bc2dcd8216a3aa
DIST botocore-1.29.21.gh.tar.gz 10994190 BLAKE2B 00a40dd701f659f63c0c0862e96922a341e8e13f2ede29c2153196810769f3c321ee66af5a4a9284ac999c5ff6bbd1b1484a1396fe97407726896b4d6860d1a1 SHA512 6743f2997221d9474f814e27ab1d6303062ed942e933619683c519a731883d1e5f06700f4730545e794cbc401ab8e20a19e08fdd06baf4cd7bac4e57bcd439c9
DIST botocore-1.29.22.gh.tar.gz 10999477 BLAKE2B 90987611453768b9c7c00ea8f6b1645bb8e5bed8ecb8b75c95452a2f20208ffed22182f8ea24bedb03f213826c3d46963f393ffc3f1465ae99620ff7f35240b7 SHA512 23c6ed2d0a9fed97467d568773d886773a06f6e4efffabbfad3b285f4d8f1844e82025b73e7fadd8c29d304c4f27e5385f63896b6ce0250e2af8b950b9a3e014
+DIST botocore-1.29.23.gh.tar.gz 11001723 BLAKE2B d1cfefb3bc25094948a1450ee7159e81d640301eca756702e8debcfa30858c22c77c273043584641888d85c46d3be800c65c2c800ecfc83b2760e7ea40e9a03b SHA512 454ac41097385838d286f3a3d9cc44e076fea8608313895ae657683ea5441328704eaa1b46a22076cad5b7e91eead5291cd036a188ab907b80173f2b755d6160
DIST botocore-1.29.8.gh.tar.gz 10636661 BLAKE2B 3ebd9e5cb6cc1a9d4ddb877e806e0a845e6a19a4604b4489dbdb9a0f35251201de5d7062f3b0193db3e28f5170d8c3315fdc0b2bec7668a61880ff3e9305d3bc SHA512 c4a1a3993576bd0340de4eeb25e10650219e9d74c21f7e51e5298120bc92a8359143c38d5a991b940316fc5eac483e4e838298881a5c068fa91dc3ebf92a7f5a
diff --git a/dev-python/botocore/botocore-1.29.23.ebuild b/dev-python/botocore/botocore-1.29.23.ebuild
new file mode 100644
index 000000000000..eed342eb3cfa
--- /dev/null
+++ b/dev-python/botocore/botocore-1.29.23.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ # fails on unrelated warnings
+ tests/unit/test_client.py::TestAutoGeneratedClient::test_BOTO_DISABLE_COMMONNAME
+ tests/unit/test_client.py::TestClientErrors::test_BOTO_DISABLE_COMMONNAME
+ # TODO
+ tests/functional/test_credentials.py::SSOSessionTest::test_token_chosen_from_provider
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}