summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Bracht Laumann Jespersen <t@laumann.xyz>2022-04-04 14:21:06 +0200
committerSam James <sam@gentoo.org>2022-04-21 20:54:40 +0100
commit8f9e87f6a70d983ff038555d5850dffd7388bd9c (patch)
tree56ad50cb9075bab299dd45210a8d03dc7c49514b
parentx11-plugins/gkrelltop: update EAPI 6 -> 8 (diff)
downloadgentoo-8f9e87f6a70d983ff038555d5850dffd7388bd9c.tar.gz
gentoo-8f9e87f6a70d983ff038555d5850dffd7388bd9c.tar.bz2
gentoo-8f9e87f6a70d983ff038555d5850dffd7388bd9c.zip
x11-plugins/gkrellm-imonc: update EAPI 6 -> 8
Signed-off-by: Thomas Bracht Laumann Jespersen <t@laumann.xyz> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--x11-plugins/gkrellm-imonc/files/gkrellm-imonc-0.2-r2-pkgconfig.patch15
-rw-r--r--x11-plugins/gkrellm-imonc/gkrellm-imonc-0.2-r2.ebuild32
2 files changed, 47 insertions, 0 deletions
diff --git a/x11-plugins/gkrellm-imonc/files/gkrellm-imonc-0.2-r2-pkgconfig.patch b/x11-plugins/gkrellm-imonc/files/gkrellm-imonc-0.2-r2-pkgconfig.patch
new file mode 100644
index 000000000000..c8c1d8fe46ff
--- /dev/null
+++ b/x11-plugins/gkrellm-imonc/files/gkrellm-imonc-0.2-r2-pkgconfig.patch
@@ -0,0 +1,15 @@
+Respect user's pkg-config
+--- a/Makefile
++++ b/Makefile
+@@ -6,8 +6,9 @@ DISTRIB_DIR= gkrellm-imonc-$(VERSION)
+ #
+ #
+
+-GTK_INCLUDE = $(shell pkg-config gtk+-2.0 --cflags)
+-GTK_LIB = $(shell pkg-config gtk+-2.0 --libs)
++PKG_CONFIG ?= pkg-config
++GTK_INCLUDE = $(shell ${PKG_CONFIG} gtk+-2.0 --cflags)
++GTK_LIB = $(shell ${PKG_CONFIG} gtk+-2.0 --libs)
+
+ FLAGS = -fPIC $(GTK_INCLUDE)
+ LIBS = $(GTK_LIB)
diff --git a/x11-plugins/gkrellm-imonc/gkrellm-imonc-0.2-r2.ebuild b/x11-plugins/gkrellm-imonc/gkrellm-imonc-0.2-r2.ebuild
new file mode 100644
index 000000000000..a06fa4d4fd66
--- /dev/null
+++ b/x11-plugins/gkrellm-imonc/gkrellm-imonc-0.2-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gkrellm-plugin toolchain-funcs
+
+DESCRIPTION="A GKrellM2 plugin to control a fli4l router"
+HOMEPAGE="http://gkrellm-imonc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-src-${PV}.tar.bz2"
+S="${WORKDIR}/${PN}-src-${PV}"
+
+# The COPYING file contains the GPLv2, but the file headers say GPLv2+.
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-admin/gkrellm:2[X]"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-makefile.patch
+ "${FILESDIR}"/${P}-r2-pkgconfig.patch
+)
+
+src_compile() {
+ tc-export PKG_CONFIG
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}"
+}