summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2023-12-21 10:27:03 -0500
committerMichael Orlitzky <mjo@gentoo.org>2024-01-22 06:29:02 -0500
commit8fa8acf560a5971355d7953323b429d5020b9145 (patch)
tree8aca2481d31a4b7e812f1b15b01fdafc5d3224d3
parentdev-gap/autodoc: new package, add 2022.10.20 (diff)
downloadgentoo-8fa8acf560a5971355d7953323b429d5020b9145.tar.gz
gentoo-8fa8acf560a5971355d7953323b429d5020b9145.tar.bz2
gentoo-8fa8acf560a5971355d7953323b429d5020b9145.zip
dev-gap/utils: new package, add 0.84
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
-rw-r--r--dev-gap/utils/Manifest1
-rw-r--r--dev-gap/utils/metadata.xml31
-rw-r--r--dev-gap/utils/utils-0.84.ebuild26
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-gap/utils/Manifest b/dev-gap/utils/Manifest
new file mode 100644
index 000000000000..a49b7c71485f
--- /dev/null
+++ b/dev-gap/utils/Manifest
@@ -0,0 +1 @@
+DIST utils-0.84.tar.gz 531664 BLAKE2B f1b8acbfa6ed2154264a7ba556290032b2d23e4d61deb94e376b4d32e28fac934b64be0768ce1c13d4f33e169f9f8161ab7269dc6d66a68bc9338880987bed27 SHA512 3a820835bf5edcb5dd904ae32207340615818f8c17ebbe87a88666ff9e0034c920733e99bd3a6a26455d0af818d87f29c6fae960afde1bc78f2d2a2cb9564369
diff --git a/dev-gap/utils/metadata.xml b/dev-gap/utils/metadata.xml
new file mode 100644
index 000000000000..0cd64a5821b4
--- /dev/null
+++ b/dev-gap/utils/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ This package collects together utility functions from a selection of
+ GAP packages in order to make them more widely visible to other
+ package authors.
+
+ Other generally useful functions, which are not deemed suitable for
+ the main library, and also welcome. For example, recent additions
+ are functions to convert certain types of group to Magma format.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">gap-packages/utils</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-gap/utils/utils-0.84.ebuild b/dev-gap/utils/utils-0.84.ebuild
new file mode 100644
index 000000000000..e8c6945c050a
--- /dev/null
+++ b/dev-gap/utils/utils-0.84.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gap-pkg
+
+DESCRIPTION="Utility functions in GAP"
+SLOT="0"
+SRC_URI="https://github.com/gap-packages/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-gap/autodoc
+ dev-gap/polycyclic"
+
+DOCS=( CHANGES.md README.md )
+
+gap-pkg_enable_tests
+
+src_prepare() {
+ # disable network tests
+ rm tst/download.tst || die
+ default
+}