summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-03-03 11:40:01 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-03-03 11:52:51 +0100
commit8face5228b029762d0f3173d96e930431b0beb24 (patch)
tree81a8ee0b5ca7043c60a87a5b211a1c9ccffa06c6
parentdev-libs/libpqxx: Bump to 7.4.1 (diff)
downloadgentoo-8face5228b029762d0f3173d96e930431b0beb24.tar.gz
gentoo-8face5228b029762d0f3173d96e930431b0beb24.tar.bz2
gentoo-8face5228b029762d0f3173d96e930431b0beb24.zip
sys-apps/help2man: Bump to version 1.48.2
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--sys-apps/help2man/Manifest1
-rw-r--r--sys-apps/help2man/help2man-1.48.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-apps/help2man/Manifest b/sys-apps/help2man/Manifest
index e53f9d5c40aa..ceb41854ccd0 100644
--- a/sys-apps/help2man/Manifest
+++ b/sys-apps/help2man/Manifest
@@ -1,3 +1,4 @@
DIST help2man-1.47.16.tar.xz 203036 BLAKE2B 8e06c2c2e90adfc2ab8345908516b15ae50b02a7a9554d5d9beee4373b71c131aeaa0c148b9a988c531bbfe2149c25069af56a79101a4248b6c1adfeb734a132 SHA512 b427e60a9e3d2e805caf1ae84c337b09c7ca6f92b7ff14771f946c4a1bf7adf177df99b9c1c223ad76df99756005ababf5b548ff8e08d4746702ff7f8150b544
DIST help2man-1.47.17.tar.xz 211476 BLAKE2B 67b1ccd4b6b66510a2fff424663bc2051e49e93c37c7e2a2b4631f3781d3773a97fd1773f96ca5ca2ba644bcd79ae35338931eff857ce199a847cc312d778b0e SHA512 185cd04aa6db6d8a4c898b61ad6a0aded7775659c7f02244b45927310eb3f8cd932fe9dd725ccac3e793aa22c656338b5d16f291f3a0420ed121681d4a4bac25
DIST help2man-1.48.1.tar.xz 210500 BLAKE2B 9993e1f0c1102025f80fb64fa1afe31efe982ef54c9d5ff88bed9038bcfe1f4d5624737e0953abeb252df78cf92a645bbbd8f3b44939d70a2b50494c22110991 SHA512 506e7a0e6571facc570df57b875d6d6b911b281b38af1831d3a058a6de658c3656e3a5be970fa3d89c053ab6eafd4853527512b48524ceeff6da60f946f1ecef
+DIST help2man-1.48.2.tar.xz 210304 BLAKE2B ea13932ae4d181be6f08720f402e4fdedfd0b88eb9c2f3b6201a2c0893846ea5fb777423f010551c375758deb81f564128b4ebdef04f6a54eb6ba50e1311c351 SHA512 ddd3bde5b9b0e84e21cc03dec713469562b02aac7f4b465fbf18844fc9534e8975ec41f44474fcf1b06816eb9b4e0578eb974a6c9712b6f099d7be813f6d7528
diff --git a/sys-apps/help2man/help2man-1.48.2.ebuild b/sys-apps/help2man/help2man-1.48.2.ebuild
new file mode 100644
index 000000000000..2f5c10989e9b
--- /dev/null
+++ b/sys-apps/help2man/help2man-1.48.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="GNU utility to convert program --help output to a man page"
+HOMEPAGE="https://www.gnu.org/software/help2man/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls"
+
+RDEPEND="dev-lang/perl
+ nls? ( dev-perl/Locale-gettext )"
+DEPEND="${RDEPEND}"
+
+DOCS=( debian/changelog NEWS README THANKS ) #385753
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.46.1-linguas.patch
+)
+
+src_prepare() {
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ sed -i \
+ -e 's/-shared/-bundle/' \
+ Makefile.in || die
+ fi
+ default
+}
+
+src_configure() {
+ # Disable gettext requirement as the release includes the gmo files #555018
+ local myeconfargs=(
+ ac_cv_path_MSGFMT=$(type -P false)
+ $(use_enable nls)
+ )
+ econf "${myeconfargs[@]}"
+}