summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-08-05 01:50:20 -0300
committerMatt Turner <mattst88@gentoo.org>2023-08-06 12:16:15 -0400
commit8fbac94d446f8ebbaad2cedfba2d5ddbe0d9af31 (patch)
treeb4a4384d6bd4b55a93a4ce63a6c61146191c8271
parentgui-libs/libadwaita: Version bump to 1.4_beta (diff)
downloadgentoo-8fbac94d446f8ebbaad2cedfba2d5ddbe0d9af31.tar.gz
gentoo-8fbac94d446f8ebbaad2cedfba2d5ddbe0d9af31.tar.bz2
gentoo-8fbac94d446f8ebbaad2cedfba2d5ddbe0d9af31.zip
sci-geosciences/gnome-maps: Version bump to 45_beta
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32178 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--sci-geosciences/gnome-maps/Manifest1
-rw-r--r--sci-geosciences/gnome-maps/gnome-maps-45_beta.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/sci-geosciences/gnome-maps/Manifest b/sci-geosciences/gnome-maps/Manifest
index 67d4080f897e..de1a7855c23c 100644
--- a/sci-geosciences/gnome-maps/Manifest
+++ b/sci-geosciences/gnome-maps/Manifest
@@ -2,3 +2,4 @@ DIST gnome-maps-44.1.tar.xz 2349152 BLAKE2B e544427972f98d13c5c072c234006c081fc0
DIST gnome-maps-44.2.tar.xz 2349116 BLAKE2B 52fd29cfa89ab76c6b041d9ae77453b75e5f9d2fe2de12d0ba1f283c4d16920156e9dffd54dfd0add9a37e66c3a4c49bb4ad43d4733f41301325f281e15fe458 SHA512 ea435f3a5a3ed9e4c3054e3fbb2f3dad253f0150f7555c734d06db3a039ece356c61294a664945b5165b004001d8724428aaed527ba0ca55fae2f7d37833e6a7
DIST gnome-maps-44.3.tar.xz 2348292 BLAKE2B 1e66780eaf5ea86e25438702ed8602801d31b128e40e48b30d01b9aecb9366168447f6d47efdc3198d4c8598dbcd439ae9a8c80e3810fc22faf1a3f1a44ea1b3 SHA512 a193b27474a3b62b3dc5ddbe082ea9718c5225d4939d939cf0050c46016fa1c173091d7a6087aa7be53e8369867b200de793a91f87971b8696207a12ec50c682
DIST gnome-maps-45.alpha.tar.xz 2948332 BLAKE2B 93b5ddc81f061a5adf24eff4e39435a3564554df7abadef3a567394006fe17904e5fd5dd4253f3bf31ecbe9c2504ae835bece43a164154d1e08c12192910a904 SHA512 b7032eef2a67436ad4bc3de87a01a2435141a976e7a77f4ddd9ae5c58ee39f923807409697f8131b89ce749336b6e3305d0da1f429267451c8eab706ae495dfb
+DIST gnome-maps-45.beta.tar.xz 2961892 BLAKE2B 62589766f2cff03a6d706b16db5619deb2b78c8747dec40b78facada50f55d40c36a5a3214ca5621889122aa235562332d771cfbe5f82be14257de88b150712d SHA512 5ad7bd906c158efb1f371ac883ade5bca4f75c11779fabf756a7523aef00f7f8462cc4deaae96da333bab4c9ff10b8df8aa1592b4c6560fe283993c4e57975ca
diff --git a/sci-geosciences/gnome-maps/gnome-maps-45_beta.ebuild b/sci-geosciences/gnome-maps/gnome-maps-45_beta.ebuild
new file mode 100644
index 000000000000..51df6029854d
--- /dev/null
+++ b/sci-geosciences/gnome-maps/gnome-maps-45_beta.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A map application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Maps"
+
+LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+# Pure introspection dependencies found by grepping imports in ${S}
+RDEPEND="
+ >=dev-libs/glib-2.66.0:2
+ >=dev-libs/gjs-1.69.2
+ >=dev-libs/gobject-introspection-0.10.1:=
+ gui-libs/gtk:4[introspection]
+ >=app-misc/geoclue-0.12.99:2.0[introspection]
+ >=gui-libs/libadwaita-1.4_alpha:1[introspection]
+ >=dev-libs/libgweather-4.2.0:4=[introspection]
+ >=sci-geosciences/geocode-glib-3.15.2:2[introspection]
+ dev-libs/libportal:=[introspection]
+ >=media-libs/libshumate-1.0.4[introspection]
+ dev-libs/libxml2:2
+ >=net-libs/rest-0.9.1:1.0[introspection]
+
+ app-crypt/libsecret[introspection]
+ media-libs/graphene[introspection]
+ net-libs/libsoup:3.0[introspection]
+ x11-libs/pango[introspection]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}