summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-02-25 19:02:46 -0800
committerMatt Turner <mattst88@gentoo.org>2022-02-25 19:09:28 -0800
commit8fca8acb895fa9fea2f3a6f0ce539b39af5f97ed (patch)
treec56ab1f4f26fa393c0358cb25ad6736f7b8a3adf
parentnet-misc/openssh: drop duplicate patch hunk (diff)
downloadgentoo-8fca8acb895fa9fea2f3a6f0ce539b39af5f97ed.tar.gz
gentoo-8fca8acb895fa9fea2f3a6f0ce539b39af5f97ed.tar.bz2
gentoo-8fca8acb895fa9fea2f3a6f0ce539b39af5f97ed.zip
x11-libs/cairo: Use upstream patches
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-libs/cairo/files/cairo-1.16.0-binutils-2.34.patch54
-rw-r--r--x11-libs/cairo/files/cairo-1.16.0-strings.patch22
2 files changed, 74 insertions, 2 deletions
diff --git a/x11-libs/cairo/files/cairo-1.16.0-binutils-2.34.patch b/x11-libs/cairo/files/cairo-1.16.0-binutils-2.34.patch
index 03daac0eca4b..a10cad5ee553 100644
--- a/x11-libs/cairo/files/cairo-1.16.0-binutils-2.34.patch
+++ b/x11-libs/cairo/files/cairo-1.16.0-binutils-2.34.patch
@@ -1,6 +1,55 @@
+From e30259f6237571c61992433c110bc6e1ef900244 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Tim-Philipp=20M=C3=BCller?= <tim@centricular.com>
+Date: Tue, 23 Feb 2021 11:36:24 +0000
+Subject: [PATCH] cairo-trace: fix build with newer versions of bfd
+
+And update configure/meson checks to check for the new function.
+
+Drop libiberty.h check since it's only needed by backtrace-symbols.c
+which we're about to remove.
+
+Closes #391, #460
+---
+ Makefile.am | 1 +
+ configure.ac | 8 +++++++-
+ meson-cc-tests/bfd-section-flags.c | 9 +++++++++
+ meson.build | 11 ++++++-----
+ util/cairo-trace/lookup-symbol.c | 7 +++----
+ 5 files changed, 26 insertions(+), 10 deletions(-)
+ create mode 100644 meson-cc-tests/bfd-section-flags.c
+
+diff --git a/configure.ac b/configure.ac
+index 18e4a305f..6444a3da3 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -826,7 +826,13 @@ CAIRO_ENABLE(interpreter, cairo-script-interpreter, yes, [
+ AC_CHECK_LIB(bfd, bfd_openr,
+ [AC_CHECK_HEADER(bfd.h, [have_bfd=yes],
+ [have_bfd=no])], [have_bfd=no])
+-AC_CHECK_HEADER(libiberty.h,, [have_bfd=no])
++dnl bfd_section_flags is an inline func so we don't bother with linking the lib in
++AC_LINK_IFELSE([AC_LANG_PROGRAM([
++ #include <bfd.h>
++ asection *s;
++],[
++ return bfd_section_flags(s) == 0;
++])],[],[have_bfd=no])
+ if test "x$have_bfd" = "xyes"; then
+ AC_DEFINE([HAVE_BFD], [1], [Define to 1 if you have the binutils development files installed])
+ BFD_LIBS=-lbfd
+diff --git a/util/cairo-trace/lookup-symbol.c b/util/cairo-trace/lookup-symbol.c
+index f9665b36f..9af0b5944 100644
--- a/util/cairo-trace/lookup-symbol.c
+++ b/util/cairo-trace/lookup-symbol.c
-@@ -145,14 +145,14 @@ find_address_in_section (bfd *abfd,
+@@ -65,7 +65,6 @@
+
+ #if HAVE_BFD
+ #include <bfd.h>
+-#include <libiberty.h>
+
+ struct symtab {
+ bfd *bfd;
+@@ -145,14 +144,14 @@ find_address_in_section (bfd *abfd,
if (symbol->found)
return;
@@ -18,3 +67,6 @@
if (symbol->pc >= vma + size)
return;
+--
+2.34.1
+
diff --git a/x11-libs/cairo/files/cairo-1.16.0-strings.patch b/x11-libs/cairo/files/cairo-1.16.0-strings.patch
index ee72f9dec7ce..2c4742887e36 100644
--- a/x11-libs/cairo/files/cairo-1.16.0-strings.patch
+++ b/x11-libs/cairo/files/cairo-1.16.0-strings.patch
@@ -1,4 +1,21 @@
-https://bugs.gentoo.org/726200
+From 23b6e8bb5798c77550da613fadc3da8b3be14573 Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyfox@gentoo.org>
+Date: Sun, 14 Jun 2020 09:58:52 +0100
+Subject: [PATCH] build/aclocal.float.m4: detect 'strings' with AC_CHECK_TOOL
+
+This way all binutils tools are detected with $CHOST prefix
+if exist. And strings is allowed to be substituted with
+STRINGS environment override, so 'llvm-strings' (or other)
+alternative can be used.
+
+Bug: https://bugs.gentoo.org/726200
+Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
+---
+ build/aclocal.float.m4 | 7 +++++--
+ 1 file changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/build/aclocal.float.m4 b/build/aclocal.float.m4
+index f92db03e6..d9728c123 100644
--- a/build/aclocal.float.m4
+++ b/build/aclocal.float.m4
@@ -31,10 +31,13 @@ int main() { return 0; }
@@ -17,3 +34,6 @@ https://bugs.gentoo.org/726200
if test "$ax_cv_c_float_words_bigendian" = unknown; then
ax_cv_c_float_words_bigendian=no
else
+--
+2.34.1
+