summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2022-03-26 20:00:25 +0100
committerSven Wegener <swegener@gentoo.org>2022-03-26 20:00:46 +0100
commit8fe5ce0380094cc7036b8c7271de856636e3132f (patch)
tree0fad64b887414fd46a0d55f5807dab711231cd2f
parentsys-kernel/gentoo-sources: drop 5.16.13 (diff)
downloadgentoo-8fe5ce03.tar.gz
gentoo-8fe5ce03.tar.bz2
gentoo-8fe5ce03.zip
net-dns/pdns-recursor: Version bump, security bug #836006
Bug: https://bugs.gentoo.org/836006 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Sven Wegener <swegener@gentoo.org>
-rw-r--r--net-dns/pdns-recursor/Manifest1
-rw-r--r--net-dns/pdns-recursor/pdns-recursor-4.6.1.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/net-dns/pdns-recursor/Manifest b/net-dns/pdns-recursor/Manifest
index 27f5e2ac676d..17e2b7bfafdb 100644
--- a/net-dns/pdns-recursor/Manifest
+++ b/net-dns/pdns-recursor/Manifest
@@ -1,3 +1,4 @@
DIST pdns-recursor-4.4.7.tar.bz2 1404116 BLAKE2B 42808634fe20735ba0a933a20b7c4dfae0c32b25976e713be46dddfcdf03599b2b29ca8407781ac304fcb004f8a8a29856dc70aeb468f4e773ee5e5a9d1e7631 SHA512 eb4008ec65e42e10d9fc4d0e0fc6c4d4716224f04f530649d88adbc505ea2a8b570bfd738455f9c769e6c242e7996905c7cc457e9f685b06e5d0f73fdffd30a7
DIST pdns-recursor-4.5.7.tar.bz2 1475537 BLAKE2B e58a28ed1ca2a9ae69436f9367e83f046ed5bc47bfd13783bd7c956f917c4a6d9c93a9a8e1c4df55ad42bc6ba024faca936fefdaffb2125e4f6635c5e6a20b19 SHA512 dc4a2a129039f79440420c285c37fd11536f2c0b74a39da74560eb782f1ad881839831e97f2a803b1812f128e899ad7c460fada42a831994b21f301f8892e60a
DIST pdns-recursor-4.6.0.tar.bz2 1549434 BLAKE2B 3834c3cf58d99ba03b9e2c325a35e7bdc29a6da3fc77998b44a875033a1ce9a538762f21270754c0207be175a2b9f06d06677822a7dffd7f57fe510425772f96 SHA512 ca7e7a4aed904a68f4dcb25e62393d44cbe5a1b64b76882b086e3dcfc08face8d399d2652aeb3c03d8a68b2c9531e78223b815256d7d9e82777621aba8ad068b
+DIST pdns-recursor-4.6.1.tar.bz2 1541000 BLAKE2B fede4f654cd9900780df8dcc39585e95d8b0536c6d14476fde6f33a2d307144f50fb7b51bf6e0c950dcaff74120a101effee0c92cf15c4acedfa94a2682b0c5c SHA512 b595dd382bb4bff5cd47bff854952c8ee40bedeafe4236f935c8eceeca7ac97e8668b884e1ec0ce490ce535fab10d161ffc53ca395c0bb02ffcf6005a692674b
diff --git a/net-dns/pdns-recursor/pdns-recursor-4.6.1.ebuild b/net-dns/pdns-recursor/pdns-recursor-4.6.1.ebuild
new file mode 100644
index 000000000000..076ff5c64a8c
--- /dev/null
+++ b/net-dns/pdns-recursor/pdns-recursor-4.6.1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit flag-o-matic lua-single
+
+DESCRIPTION="The PowerDNS Recursor"
+HOMEPAGE="https://www.powerdns.com/"
+SRC_URI="https://downloads.powerdns.com/releases/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug dnstap snmp sodium systemd test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+DEPEND="${LUA_DEPS}
+ dnstap? ( dev-libs/fstrm )
+ systemd? ( sys-apps/systemd:0= )
+ snmp? ( net-analyzer/net-snmp )
+ sodium? ( dev-libs/libsodium:= )
+ dev-libs/openssl:=
+ >=dev-libs/boost-1.35:="
+RDEPEND="${DEPEND}
+ !<net-dns/pdns-2.9.20-r1
+ acct-user/pdns
+ acct-group/pdns"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}"/${P/_/-}
+
+pkg_setup() {
+ lua-single_pkg_setup
+ filter-flags -ftree-vectorize
+ append-lfs-flags
+ append-cppflags -D_TIME_BITS=64
+}
+
+src_configure() {
+ econf \
+ --sysconfdir=/etc/powerdns \
+ --with-nod-cache-dir=/var/lib/powerdns \
+ --with-service-user=pdns \
+ --with-service-group=pdns \
+ --with-lua="${ELUA}" \
+ $(use_enable debug verbose-logging) \
+ $(use_enable systemd) \
+ $(use_enable dnstap dnstap) \
+ $(use_enable test unit-tests) \
+ $(use_with sodium libsodium) \
+ $(use_with snmp net-snmp)
+}
+
+src_install() {
+ default
+
+ mv "${D}"/etc/powerdns/recursor.conf{-dist,}
+
+ # set defaults: setuid=nobody, setgid=nobody
+ sed -i \
+ -e 's/^# set\([ug]\)id=$/set\1id=pdns/' \
+ -e 's/^# quiet=$/quiet=on/' \
+ -e 's/^# chroot=$/chroot=\/var\/lib\/powerdns/' \
+ "${D}"/etc/powerdns/recursor.conf
+
+ newinitd "${FILESDIR}"/pdns-recursor-r2 pdns-recursor
+}
+
+pkg_postinst() {
+ local old
+
+ for old in ${REPLACING_VERSIONS}; do
+ ver_test ${old} -lt 4.0.0-r1 || continue
+
+ ewarn "Starting with 4.0.0-r1 the init script has been renamed from precursor"
+ ewarn "to pdns-recursor, please update your runlevels accordingly."
+
+ break
+ done
+}