summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2018-10-21 14:24:31 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2018-10-24 21:35:06 -0700
commit8fefffc0fcf576ec1e0661ae87dc61d8197a35b9 (patch)
tree77af95187c493f5c327b45c6df2e70067a2af805
parentnet-wireless/wireless-regdb: bump (diff)
downloadgentoo-8fefffc0.tar.gz
gentoo-8fefffc0.tar.bz2
gentoo-8fefffc0.zip
dev-python/grpcio: new package
Split from net-libs/grpc[python] Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--dev-python/grpcio/Manifest1
-rw-r--r--dev-python/grpcio/grpcio-1.16.0.ebuild36
-rw-r--r--dev-python/grpcio/metadata.xml15
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/grpcio/Manifest b/dev-python/grpcio/Manifest
new file mode 100644
index 000000000000..e3589291b88b
--- /dev/null
+++ b/dev-python/grpcio/Manifest
@@ -0,0 +1 @@
+DIST grpcio-1.16.0.tar.gz 14519470 BLAKE2B 872ef15a7994303ce7ac0a573e49c94260eb8480d8ee94e25471ec9395827fafd3f5e3bd6f4793eb15091827e6d780b8dd6d01f38eef85db80fb234a710f370b SHA512 37d5940f1543cebdabf2b1340a042f98e5f321c42d92d05c88631c0eae42d94d3fe86893a21704a22b70c1fbd70bf091c1af2b51cd5c1d316dd8f0a586fb0eb7
diff --git a/dev-python/grpcio/grpcio-1.16.0.ebuild b/dev-python/grpcio/grpcio-1.16.0.ebuild
new file mode 100644
index 000000000000..312146bd5e1a
--- /dev/null
+++ b/dev-python/grpcio/grpcio-1.16.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="High-performance RPC framework (python libraries)"
+HOMEPAGE="https://grpc.io"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-libs/openssl-1.0.2:0=[-bindist]
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ net-dns/c-ares:=
+ !<net-libs/grpc-1.16.0[python]
+ sys-libs/zlib:=
+ virtual/python-enum34[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_compile() {
+ export GRPC_PYTHON_BUILD_SYSTEM_CARES=1
+ export GRPC_PYTHON_BUILD_SYSTEM_OPENSSL=1
+ export GRPC_PYTHON_BUILD_SYSTEM_ZLIB=1
+ export GRPC_PYTHON_BUILD_WITH_CYTHON=1
+ distutils-r1_python_compile
+}
diff --git a/dev-python/grpcio/metadata.xml b/dev-python/grpcio/metadata.xml
new file mode 100644
index 000000000000..011f4a88ece5
--- /dev/null
+++ b/dev-python/grpcio/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gyakovlev@gentoo.org</email>
+ <name>Georgy Yakovlev</name>
+ </maintainer>
+ <longdescription lang="en">
+ High-performance RPC framework (python libraries)
+ </longdescription>
+ <upstream>
+ <remote-id type="github">grpc/grpc</remote-id>
+ <remote-id type="pypi">grpcio</remote-id>
+ </upstream>
+</pkgmetadata>