summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-01 12:32:16 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-01 13:06:57 +0200
commit900d9cf10cf0633546e6d33541199b0434d59302 (patch)
treef9ce6dc2ca659db07af720ac5ec3e919da74559e
parentdev-python/tifffile: Bump to 2022.7.31 (diff)
downloadgentoo-900d9cf10cf0633546e6d33541199b0434d59302.tar.gz
gentoo-900d9cf10cf0633546e6d33541199b0434d59302.tar.bz2
gentoo-900d9cf10cf0633546e6d33541199b0434d59302.zip
dev-python/imageio: Bump to 2.21.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/imageio/Manifest1
-rw-r--r--dev-python/imageio/imageio-2.21.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/imageio/Manifest b/dev-python/imageio/Manifest
index 0a7aef176983..1fd70e722c29 100644
--- a/dev-python/imageio/Manifest
+++ b/dev-python/imageio/Manifest
@@ -1,3 +1,4 @@
DIST imageio-2.19.3.gh.tar.gz 388949 BLAKE2B bf7f7b2cc036d6bc808cedeefe624dfe43b232518f78974fffe9c664f23c8e89da73e5b777ee6049aa0ec363400fe8d9df1388a91a4b0a01089609d7ce12eaf3 SHA512 5ad9f332ea723facd5d9295e463b12d2cc17dfef8a7349ce194a8d32fcc5d07a29550834c66dc6e5837f8440347387b46624243fa267750f986042910ff6cb90
DIST imageio-2.19.5.gh.tar.gz 389832 BLAKE2B a4455f97d2607d215ba4797e076487f4648ae6b21bf7b5207df8f337b52319ba4dd415d6e351289b588a049c800e8c541fcdaefe064cb4c83de12e63c492cf83 SHA512 481f14116961927946a71a7448ecf38f9781172969ab4e35c05360d758f7273be22262d4cd774a76b2089be3b7f0af6cf0a67d40814504e7a65db7075428966c
DIST imageio-2.20.0.gh.tar.gz 390281 BLAKE2B 745364f98e3835c428e89abbfbeeb657d10cd730cd61283e5859b10a6e48b63a5b9771860fce75aa8dd770ab77671979847b34bbffe17d215fac5ceb8eb2c7d1 SHA512 fc1c41559cc15b76bfacbf4866717c200889661787de4baa49d69fab189ff7d00e376afdeeaaf74b5581e1ffc96da2f02566dfa9c0953518b98a4c4b695ddf02
+DIST imageio-2.21.0.gh.tar.gz 391056 BLAKE2B 90fbacf7b396ab2b422d8694274ddc3642c92cfd325bce2861100f5bd28d82120cef6819b53b8ed82ba474d5e287765b63da9a7edfbfab5a026790a39d4edc1e SHA512 5bb070da560ba3a2e10bdb288ad539274ee14f8cf0543847859f0bae052b3d1782777d823435b74120bcfdff0b6cb15a6c80b2a9bf729439bbb3802f15cf5684
diff --git a/dev-python/imageio/imageio-2.21.0.ebuild b/dev-python/imageio/imageio-2.21.0.ebuild
new file mode 100644
index 000000000000..6770d9759db9
--- /dev/null
+++ b/dev-python/imageio/imageio-2.21.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for reading and writing image data"
+HOMEPAGE="
+ https://imageio.readthedocs.io/en/stable/
+ https://github.com/imageio/imageio/
+ https://pypi.org/project/imageio/
+"
+SRC_URI="
+ https://github.com/imageio/imageio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# over 50% of tests rely on Internet
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/numpy-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/pillow-8.3.2[${PYTHON_USEDEP}]
+ media-libs/freeimage
+"
+# requests for fsspec[github]
+BDEPEND="
+ test? (
+ dev-python/fsspec[${PYTHON_USEDEP}]
+ dev-python/imageio-ffmpeg[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tifffile[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Fails because of system installed freeimage
+ tests/test_core.py::test_findlib2
+ # Tries to download ffmpeg binary ?!
+ tests/test_ffmpeg.py::test_get_exe_installed
+)