summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2023-08-15 11:13:21 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2023-08-15 11:13:21 +0200
commit90117800a8b77c9de7bcd4f49a40064464634da2 (patch)
tree91a76f6237bf4dad6c3b21212de1cb011210bce5
parentwww-servers/tomcat: bump to 8.5.92 (diff)
downloadgentoo-90117800.tar.gz
gentoo-90117800.tar.bz2
gentoo-90117800.zip
media-sound/gpodder: bump to 3.11.2
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
-rw-r--r--media-sound/gpodder/Manifest1
-rw-r--r--media-sound/gpodder/gpodder-3.11.2.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/media-sound/gpodder/Manifest b/media-sound/gpodder/Manifest
index e275b9815841..005fab7ce5cb 100644
--- a/media-sound/gpodder/Manifest
+++ b/media-sound/gpodder/Manifest
@@ -1 +1,2 @@
DIST gpodder-3.11.1.tar.gz 1174163 BLAKE2B 703b545b576c8f119427e336e71e45301d4336fc82bca6ec6c4a0866591c8742866308da680564ff1543a5a65e2407295c46b3c5831d1e2d7335c5806d4cce5a SHA512 7570a4f0ac0c974fab58e30bb5bceb998cd7260ab91140a9801cf4fda1af3549ddf1ec4930081025215ecefd920a93c16252594915778e8ecb7524d3d7d3011b
+DIST gpodder-3.11.2.tar.gz 1177302 BLAKE2B de66191dd50f5041b10f52c18be31e059f6547c12f7e81f036939b3fdf1a9de5e18d6a25dac9db9487e3efa907c9967e220f41386929b9053fe1e5670b6babe7 SHA512 367c1e0eba7a5973b681e7b91463624b4e9ef2ad75ce1697f5d2e5937958c417bc3e6b1b34a54344f66ebb047479ab16a35dd913e54050f71ac54af05e62b30a
diff --git a/media-sound/gpodder/gpodder-3.11.2.ebuild b/media-sound/gpodder/gpodder-3.11.2.ebuild
new file mode 100644
index 000000000000..d6e67e460c88
--- /dev/null
+++ b/media-sound/gpodder/gpodder-3.11.2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 optfeature xdg
+
+DESCRIPTION="A free cross-platform podcast aggregator"
+HOMEPAGE="https://gpodder.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+dbus bluetooth mtp"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/podcastparser[${PYTHON_USEDEP}]
+ dev-python/mygpoclient[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dbus? ( dev-python/dbus-python[${PYTHON_USEDEP}] )
+ ')
+ bluetooth? ( net-wireless/bluez )
+ mtp? ( media-libs/libmtp:= )
+ kernel_linux? ( sys-apps/iproute2 )
+"
+BDEPEND="
+ dev-util/desktop-file-utils
+ dev-util/intltool
+ sys-apps/help2man
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/minimock[${PYTHON_USEDEP}]
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ default
+
+ sed -i -e 's:--cov=gpodder::' makefile || die
+}
+
+python_test() {
+ # These are pulled out from the Makefile to give us more control
+ # See bug #795165
+ # Previously, we used 'emake releasetest' in src_test
+ LC_ALL=C epytest --ignore=tests --ignore=src/gpodder/utilwin32ctypes.py --doctest-modules src/gpodder/util.py src/gpodder/jsonconfig.py \
+ -p no:localserver
+ LC_ALL=C epytest tests --ignore=src/gpodder/utilwin32ctypes.py --ignore=src/mygpoclient \
+ -p no:localserver
+}
+
+src_install() {
+ emake PYTHON="${EPYTHON}" DESTDIR="${D}" install
+
+ distutils-r1_src_install
+
+ touch "${ED}"/usr/share/gpodder/no-update-check || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "track length detection for device sync (only one package is needed)" media-video/mplayer dev-python/eyeD3
+ optfeature "for the YouTube extension" net-misc/yt-dlp
+ optfeature "iPod sync support" media-libs/libgpod
+}