summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-06-03 11:55:47 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-06-03 11:55:47 -0400
commit90195487e35ee838e6b22a1a971bbf5e8187a2a1 (patch)
tree4979b84e7d26e5863b1231a14a561c6c2140700e
parentapp-crypt/tpm-tools: add libressl support (diff)
downloadgentoo-90195487.tar.gz
gentoo-90195487.tar.bz2
gentoo-90195487.zip
app-crypt/xca: add libressl support
Package-Manager: portage-2.2.28
-rw-r--r--app-crypt/xca/xca-1.3.2-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-crypt/xca/xca-1.3.2-r1.ebuild b/app-crypt/xca/xca-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..58491e0b4003
--- /dev/null
+++ b/app-crypt/xca/xca-1.3.2-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A GUI to OpenSSL, RSA public keys, certificates, signing requests and revokation lists"
+HOMEPAGE="http://xca.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="bindist libressl"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0=[bindist=] )
+ libressl? ( dev-libs/libressl:0= )
+ dev-qt/qtgui:4"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0.0-desktop.patch
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ STRIP=true
+}
+
+src_compile() {
+ # enforce all to avoid the automatic silent rules
+ emake all
+}
+
+src_install() {
+ # non standard destdir
+ emake install destdir="${ED}"
+
+ insinto /etc/xca
+ doins misc/*.txt
+}