summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-10-01 07:38:24 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-01 08:41:33 +0300
commit901e1545d20758b55ba79c46538c78f19a40d989 (patch)
treee4ecfc9294cd44f3cd97cc5b7f96e85894bdd10d
parentapp-misc/jp: 0.2.1 bump with jmespath upstream (diff)
downloadgentoo-901e1545.tar.gz
gentoo-901e1545.tar.bz2
gentoo-901e1545.zip
dev-python/debtcollector: add 2.3.0, enable tests
Closes: https://bugs.gentoo.org/797478 Closes: https://bugs.gentoo.org/732976 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/debtcollector/Manifest1
-rw-r--r--dev-python/debtcollector/debtcollector-2.3.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/debtcollector/Manifest b/dev-python/debtcollector/Manifest
index dbd8f1273768..8e0c7c06dc30 100644
--- a/dev-python/debtcollector/Manifest
+++ b/dev-python/debtcollector/Manifest
@@ -1 +1,2 @@
DIST debtcollector-2.2.0.tar.gz 28833 BLAKE2B 33361daaba12c52a1cc0bac168199ef3dbb959279def29ef782fa421f0aa106038de02217f6321c64e02845abd0573e69f5638b384411e7fbfd194dd3f6b3356 SHA512 6e5fdf38a25406a7a56d18e9b900471e3e4ce513ef62619c9eafa153ea08ff6b4b9bd90c524cfa16e04ff0c9c324e90d4fdd75212fced0b202245cdddae02137
+DIST debtcollector-2.3.0.tar.gz 31537 BLAKE2B 6c4993edf08dd72e8378bd82e4578a491f0540d35165e3c67e918ef5a659de06e4fd83d2737458cddd27ef08dfd01a38679b940e80a4b460e145ab20789940e5 SHA512 d8a9a65ec33bf6bc777d6766842cd6351c265752f552bda3bfd1db86a08c8c89c3f871c6eff15648a8c1a79d7820368711256d404934fd826ee6cb0c7c53f77a
diff --git a/dev-python/debtcollector/debtcollector-2.3.0.ebuild b/dev-python/debtcollector/debtcollector-2.3.0.ebuild
new file mode 100644
index 000000000000..78c052a7a9dc
--- /dev/null
+++ b/dev-python/debtcollector/debtcollector-2.3.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python deprecation patterns and strategies that collect technical debt"
+HOMEPAGE="https://www.openstack.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/wrapt-1.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/subunit[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest