summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-04-03 10:19:14 -0700
committerMatt Turner <mattst88@gentoo.org>2022-04-03 10:19:22 -0700
commit901edf6314d123a33cfb47459c5f2c03c38a050b (patch)
tree2d9f83426263aa88587fcaa87a6c2bda0f96ac5e
parentx11-libs/libX11: Version bump to 1.7.5 (diff)
downloadgentoo-901edf63.tar.gz
gentoo-901edf63.tar.bz2
gentoo-901edf63.zip
x11-misc/compose-tables: Version bump to 1.7.5
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-misc/compose-tables/Manifest1
-rw-r--r--x11-misc/compose-tables/compose-tables-1.7.5.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/x11-misc/compose-tables/Manifest b/x11-misc/compose-tables/Manifest
index 3e839d0160ac..756a6a40d66d 100644
--- a/x11-misc/compose-tables/Manifest
+++ b/x11-misc/compose-tables/Manifest
@@ -1,2 +1,3 @@
DIST libX11-1.7.3.tar.xz 1861304 BLAKE2B e0f647ef55567b1d7eff74bc053b8e73f8c696be6f233c2ff6f64dee65c1b40b746683ea7a6fafb4304eba4dec43301b4b3506e2ec6fac1d4c89d664b516bbdd SHA512 abc70837d19f7e104a5db1e6d2cfa1256625332c0b53fec44a0a39916a60a430bb53fd436207892aabe4199ac7a0f9287a06588fcd27e0eed54d45d67bbe1294
DIST libX11-1.7.4.tar.xz 1872992 BLAKE2B 6a25e5008ead53be5af7411f51711789eb410473f9aefc49fb4d0bf7227b89c5fd71f0f61fef9bc3f83e585e4815644f42884d5e5cf0bdcdd120abe6fe8a741b SHA512 8bfaaf9fc3081c47152d533d30cdc0b2521bfeb088ff813b041c08ffd518c80ba3725bb68cac7c21b521a4bace546f99424700fe21955b498015d14c2f7f9a57
+DIST libX11-1.7.5.tar.xz 1853152 BLAKE2B 95ceccbfd37d8a749a533bdc03feba94236a47185a2cd7ad6592c534c17636906b735aa5800d810d13d3e342e3dbe281bb1f1f3ecab9d07e6a6a50f33beef8af SHA512 ef33e2f631226cab27657f46e1fd4cfc928f62f928d8297474e7b993017c8f92b60272eed6515990cdf3a9d34581837b7a3896e584f3546dd26f3790034df347
diff --git a/x11-misc/compose-tables/compose-tables-1.7.5.ebuild b/x11-misc/compose-tables/compose-tables-1.7.5.ebuild
new file mode 100644
index 000000000000..4cdfc490b634
--- /dev/null
+++ b/x11-misc/compose-tables/compose-tables-1.7.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_MULTILIB=no
+XORG_TARBALL_SUFFIX=xz
+inherit xorg-3
+
+# Note: please bump this with x11-libs/libX11
+DESCRIPTION="X.Org Compose Key tables from libX11"
+# xorg-3.eclass would attempt to fetch a tarball with a matching name to this package
+SRC_URI="${XORG_BASE_INDIVIDUAL_URI}/lib/libX11-${PV}.tar.${XORG_TARBALL_SUFFIX}"
+S="${WORKDIR}/libX11-${PV}/"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+# Only needed by configure
+DEPEND="
+ x11-base/xorg-proto
+ >=x11-libs/libxcb-1.11.1
+ x11-libs/xtrans"
+RDEPEND="!<x11-libs/libX11-1.7.0"
+
+XORG_CONFIGURE_OPTIONS=(
+ --without-xmlto
+ --without-fop
+ --disable-specs
+ --disable-xkb
+)
+
+src_compile() {
+ emake -C nls
+}
+
+src_test() {
+ :;
+}
+
+src_install() {
+ emake DESTDIR="${D}" -C nls install
+}