summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDouglas Agbeve <douglas@agbeve.com>2022-10-27 12:40:41 +0200
committerMatt Turner <mattst88@gentoo.org>2022-11-03 23:11:31 -0400
commit90342f0c62ef958af76504e5e8945ca9e267f29a (patch)
tree767c3a19a73355dbf3fcc2cccda52420c9156b61
parentsys-libs/freeipmi: fix build w/ clang 16 (diff)
downloadgentoo-90342f0c.tar.gz
gentoo-90342f0c.tar.bz2
gentoo-90342f0c.zip
sys-firmware/sof-firmware: bump to v2.2.2
Signed-off-by: Douglas Agbeve <douglas@agbeve.com> Closes: https://github.com/gentoo/gentoo/pull/27975 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--sys-firmware/sof-firmware/Manifest1
-rw-r--r--sys-firmware/sof-firmware/sof-firmware-2.2.2.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/sys-firmware/sof-firmware/Manifest b/sys-firmware/sof-firmware/Manifest
index d9475a9d5110..4c9734fc2883 100644
--- a/sys-firmware/sof-firmware/Manifest
+++ b/sys-firmware/sof-firmware/Manifest
@@ -1,2 +1,3 @@
DIST sof-firmware-2.1.1.tar.gz 4056718 BLAKE2B 0246f6240504d3e8b609b402c41ffe6ed9b8350b6a31c6567851069354e5de5b4ca6d803e78fdde77cdaba7be87c8a8923b2d0fdd0544fd3b28d1e332cd59b63 SHA512 77e9562f67014d78b213fe428edef6a08dcc058a9a762da09a486c002c3aa0b907ea7c8ba6d4f88f5ddab5e564de06df9f2ed77206341a0fe2e1aaab1d9740ce
+DIST sof-firmware-2.2.2.tar.gz 4116116 BLAKE2B e5722242e4b0130086ddb1b12d2adf29254bcae294f3ff49ac07dab3eab75e352a30346dd07c73ac51112b4c5234dc116de81251e01b146328cab673711f1f4c SHA512 6a3be7088f8a93a052563e040a588c600512d08d4b75ae5567db255e334997a6401d41863dcb416562eee07fef0bd2abe1d9d0403cd236ab007474f66271db50
DIST sof-firmware-2.2.tar.gz 4211499 BLAKE2B c0ab39cba3ef3dd19b67d714b5a4e5a6a6cb3e8fb2d290c3fceadeb3f7dd96db986411184e16bca56bdd1905a697f8d416cd4aa5bdff90fe32e96713ff87bb71 SHA512 3cd06f6b8f8d6c3379b987cffa019a0d84263b8e00de40c18516c3e90745d5e150bdf71a8005b1ba704e44bf84d7030195e9c0ebfcd6e35228f4c14e9290cd95
diff --git a/sys-firmware/sof-firmware/sof-firmware-2.2.2.ebuild b/sys-firmware/sof-firmware/sof-firmware-2.2.2.ebuild
new file mode 100644
index 000000000000..b51c9026bd32
--- /dev/null
+++ b/sys-firmware/sof-firmware/sof-firmware-2.2.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Sound Open Firmware (SOF) binary files"
+HOMEPAGE="https://www.sofproject.org https://github.com/thesofproject/sof https://github.com/thesofproject/sof-bin"
+SRC_URI="https://github.com/thesofproject/sof-bin/releases/download/v${PV}/sof-bin-v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/sof-bin-v${PV}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# Needed for sof-ctl
+RDEPEND="media-libs/alsa-lib"
+
+QA_PREBUILT="usr/bin/sof-ctl
+ usr/bin/sof-logger
+ usr/bin/sof-probes"
+
+src_install() {
+ dodir /lib/firmware/intel
+ dodir /usr/bin
+ FW_DEST="${D}/lib/firmware/intel" TOOLS_DEST="${D}/usr/bin" "${S}/install.sh" v${PV} || die
+}
+
+pkg_preinst() {
+ local sofpath="${EROOT}/lib/firmware/intel/sof"
+ if [[ ! -L "${sofpath}" && -d "${sofpath}" ]] ; then
+ rm -r "${sofpath}" || die
+ fi
+}