summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-11 09:35:12 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-11 10:05:36 +0200
commit903b0b87370ccd5b9d50da0b79c3440efa73df77 (patch)
treeda16e674dea41a5a6fb5141d3717aabe42fc86c5
parentdev-python/django-cors-headers: Bump to 3.12.0 (diff)
downloadgentoo-903b0b87370ccd5b9d50da0b79c3440efa73df77.tar.gz
gentoo-903b0b87370ccd5b9d50da0b79c3440efa73df77.tar.bz2
gentoo-903b0b87370ccd5b9d50da0b79c3440efa73df77.zip
dev-python/django-auth-ldap: Bump to 4.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/django-auth-ldap/Manifest1
-rw-r--r--dev-python/django-auth-ldap/django-auth-ldap-4.1.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/django-auth-ldap/Manifest b/dev-python/django-auth-ldap/Manifest
index acd3ceaf4d13..5068e159872a 100644
--- a/dev-python/django-auth-ldap/Manifest
+++ b/dev-python/django-auth-ldap/Manifest
@@ -1,2 +1,3 @@
DIST django-auth-ldap-3.0.0.tar.gz 52381 BLAKE2B 6964b36d72b365899d4dd3dc96f16b9c1f12c06ad95c7d387ec27ac6dbc38807e16fdb953e172fcde1a0d4042f318d276b780e474d9b810325e97cd601d070b7 SHA512 105885e62fd22aace2cbe291a107046109a91507ba77257b9b428e6d49fb74b6f47116f1d8325c3fc186590b00fb2b46507dc5b73333707e56d84e9a7b926d9e
DIST django-auth-ldap-4.0.0.gh.tar.gz 48798 BLAKE2B 6371afa08bd532955e1d78c26470f9dc3a536de4f98afe615611947df26cb9a970f82f7772ba42062ffea6bcfc738bb0ff5e7ff148a7d5d6968c326cfbc70f38 SHA512 d9052227fd7d8c8343eb0c7117b86483ad72640e1e6b238e5b303475d45f25851689c6cac1343131bf6c127706e7ae2a040da840272288f3e0e99e2bf2f68afe
+DIST django-auth-ldap-4.1.0.gh.tar.gz 49533 BLAKE2B f99050c147d179a54fe052e72a9b2ded556819da788f5180225a6d5015d2b7b52dc6f6d65fac4d1b88dc28b3617f9caaac7df3e455d218e8a2c6af1391418b8e SHA512 d55710cf96916602d29b33e111eff7922011231c47f843660cf2adfdc226dd335d4e42e5c2933bd77a9ee5f816d044798e876c8d0de824dcf4a8a78e1bce3446
diff --git a/dev-python/django-auth-ldap/django-auth-ldap-4.1.0.ebuild b/dev-python/django-auth-ldap/django-auth-ldap-4.1.0.ebuild
new file mode 100644
index 000000000000..fb63e13a3d4d
--- /dev/null
+++ b/dev-python/django-auth-ldap/django-auth-ldap-4.1.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Django LDAP authentication backend"
+HOMEPAGE="
+ https://github.com/django-auth-ldap/django-auth-ldap/
+ https://pypi.org/project/django-auth-ldap/
+"
+SRC_URI="
+ https://github.com/django-auth-ldap/django-auth-ldap/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+LICENSE="BSD-2"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]
+ >=dev-python/python-ldap-3.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_impl_dep sqlite)
+ net-nds/openldap[-minimal]
+ )
+"
+
+distutils_enable_sphinx docs --no-autodoc
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ # for slapd and slapdtest
+ local -x SBIN=/usr/sbin:/usr/$(get_libdir)/openldap
+ "${EPYTHON}" -m django test -v 2 --settings tests.settings ||
+ die "Tests failed with ${EPYTHON}"
+}