summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Bamford <neddyseagoon@gentoo.org>2016-06-04 16:23:44 +0100
committerPatrice Clement <monsieurp@gentoo.org>2016-06-05 07:30:26 +0000
commit90509a909c8bbce47525761da1af058f5c7a7709 (patch)
treeb5b5103c5233e9af71261bbd031f9a96a2d62165
parentvirtual/qmail: Removed mail-mta/netqmail-1.05 from RDEPEND (diff)
downloadgentoo-90509a909c8bbce47525761da1af058f5c7a7709.tar.gz
gentoo-90509a909c8bbce47525761da1af058f5c7a7709.tar.bz2
gentoo-90509a909c8bbce47525761da1af058f5c7a7709.zip
mail-filter/spamdyke: Added version spamdyke-5.0.1
This addresses bug 548178 which was for spamdyke-5.0.0 Tested on hardened ~amd64 unable to test on ~x86. Package-Manager: portage-2.3.0_rc1 Gentoo-Bug: https://bugs.gentoo.org/548178 Closes: https://github.com/gentoo/gentoo/pull/1606 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
-rw-r--r--mail-filter/spamdyke/Manifest1
-rw-r--r--mail-filter/spamdyke/spamdyke-5.0.1.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/mail-filter/spamdyke/Manifest b/mail-filter/spamdyke/Manifest
index c8140dc46b35..b83e1fb87db0 100644
--- a/mail-filter/spamdyke/Manifest
+++ b/mail-filter/spamdyke/Manifest
@@ -1 +1,2 @@
DIST spamdyke-4.3.0.tgz 525399 SHA256 6a217cfd513c3414d859cc107cc7528f94b1c452764ed192ef5774eddf4111c3 SHA512 6ba4b440e6d20e677c39439c78037ae3e2ff291bde7f48500a4e2eac8a3f17eeb7230b8ded7feee60c66f01b6aec2d259eb2d9a5794535860345957b1102d118 WHIRLPOOL c5d2cd8ba5ea31b0dcda0dbed661a3df238d9c79fbeaf2163594c1ac1471b2e9db64e290c5b0fb10e03210cae3e4109409d5c04464ce1f0364896afd980b8969
+DIST spamdyke-5.0.1.tgz 383720 SHA256 9d096921a4efd8d84e2de7b28af4acc6c00d57fd60b47aa4f96fec8813247770 SHA512 a022c8a8d4a8d74f5249f8e2d901d3de423ee853bbaffaf7e86cece1d19880d9039135892ef6ccb8a2a0fb11532c487402dc97a8dd6d89c9de431752c55f6eb9 WHIRLPOOL e9995c1bf017f9929129e9095be7d8fea22f695fec01405093f500fcab3a3c93c55dc5113536b41be3bd29650104931868e51a0b31d64a97458e4e3b946cf52f
diff --git a/mail-filter/spamdyke/spamdyke-5.0.1.ebuild b/mail-filter/spamdyke/spamdyke-5.0.1.ebuild
new file mode 100644
index 000000000000..cc117b763b35
--- /dev/null
+++ b/mail-filter/spamdyke/spamdyke-5.0.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils autotools
+
+DESCRIPTION="A drop-in connection-time spam filter for qmail"
+HOMEPAGE="http://www.spamdyke.org/"
+SRC_URI="http://www.spamdyke.org/releases/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl +ssl"
+
+DEPEND="
+ ssl? (
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+ )"
+RDEPEND="${DEPEND}
+ virtual/qmail"
+
+S=${WORKDIR}/${P}/${PN}
+
+src_prepare() {
+ echo "# Configuration option for ${PN}" > ${PN}.conf
+ if use ssl; then
+ echo "tls-certificate-file=/var/qmail/control/clientcert.pem" \
+ >> ${PN}.conf
+ fi
+ echo "graylist-level=always-create-dir" >> ${PN}.conf
+ echo "graylist-dir=/var/tmp/${PN}/graylist" >> ${PN}.conf
+ echo "reject-empty-rdns" >> ${PN}.conf
+ echo "reject-unresolvable-rdns" >> ${PN}.conf
+ echo "dns-blacklist-entry=zen.spamhaus.org" >> ${PN}.conf
+ echo "local-domains-file=/var/qmail/control/rcpthosts" >> ${PN}.conf
+ sed -i \
+ -e "/STRIP_CMD/d" \
+ Makefile.in || die "sed on Makefile.in failed"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable ssl tls) || die "econf failed"
+ cd ../utils
+ econf || die "econf failed in utils"
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
+ cd ../utils
+ emake CFLAGS="${CFLAGS}" || die "emake in utils died"
+}
+
+src_install() {
+ insinto /etc/${PN}
+ doins ${PN}.conf || die "Installing ${PN} configuration file failed"
+ dodir /var/tmp/${PN}/graylist
+ fowners -R qmaild /var/tmp/${PN}/graylist
+ cd ../utils
+ dobin domain2path || die "Installing domain2path binary failed"
+ cd ../documentation
+ dodoc {Changelog,INSTALL,UPGRADING}.txt
+ dohtml FAQ.html \
+ README.html \
+ README_ip_file_format.html \
+ README_rdns_directory_format.html \
+ README_rdns_file_format.html
+}
+
+pkg_postinst() {
+ ewarn "Change /var/qmail/control/conf-common:SOFTLIMIT_OPTS="-m 16000000""
+ ewarn "to 32000000 or spamdyke will fail to load"
+ elog "In /var/qmail/control/conf-smtpd insert the line:"
+ elog "QMAIL_SMTP_PRE=\"${QMAIL_SMTP_PRE} spamdyke -f /etc/${PN}/${PN}.conf\""
+ elog "Run spamdyke with the '-h' flag to see the available options and"
+ elog "update /etc/spamdyke/spamdyke.conf accordingly"
+}