summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsen Arsenović <arsen@gentoo.org>2023-07-03 10:16:52 +0200
committerArsen Arsenović <arsen@gentoo.org>2023-07-03 10:18:24 +0200
commit905d024a32fc0172981ab25d9e088df2abb87e7b (patch)
tree4e05f1300de84f763eab387290304c4901b0e189
parentnet-analyzer/gsad: add 22.5.1 (diff)
downloadgentoo-905d024a32fc0172981ab25d9e088df2abb87e7b.tar.gz
gentoo-905d024a32fc0172981ab25d9e088df2abb87e7b.tar.bz2
gentoo-905d024a32fc0172981ab25d9e088df2abb87e7b.zip
app-emacs/jinx: add 0.9
Signed-off-by: Arsen Arsenović <arsen@gentoo.org>
-rw-r--r--app-emacs/jinx/Manifest1
-rw-r--r--app-emacs/jinx/jinx-0.9.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-emacs/jinx/Manifest b/app-emacs/jinx/Manifest
index ba67f78e4334..e4e0c3b9152d 100644
--- a/app-emacs/jinx/Manifest
+++ b/app-emacs/jinx/Manifest
@@ -1,2 +1,3 @@
DIST jinx-0.7.tar.xz 17816 BLAKE2B d31ae1c35c5808237890c5c6ecaab915af7cc70260ae05de06c049a9bc250c3ff824a18256715fb7ed12e02df60b24aa957192b95fd3a0ab28e5102f5cf63718 SHA512 ed291b1d5eb5b799f629ed3d0d5bfca65e7f11d9349a672f09087a47ebe65a7bc8bef8fda6d344472dc8bc14c97c5d49c79365d45da5c9570e0cf84d51723928
DIST jinx-0.8.tar.xz 19064 BLAKE2B f5c2382e635b4266ac7ea4a500f3ca56f029c1104608ae12570a5983e971dff17bd2d4c7c721b080ac7ab136e7a7cc305cc96b2a5dc825caf17c5713d37702d8 SHA512 63ef5031252a98e3c4e22a331fbe99d6fb0465f965fbf7ce4e319514b2ddd8230db66d48c72bc5d957a77b2c8609f08636f1579fe4cefb44e2f56b654638fb52
+DIST jinx-0.9.tar.xz 20852 BLAKE2B 09a6a765cf51c2efe3a90317cdaeff03c2bc35bd6202b71070a19d51189c2ee6fc7406881130986dcdcfd9a9f6cec4aee25e0e71924a38aca7708aa3b99eb550 SHA512 a61e377fdee84fc91c3714f12f1bfffd95d6618a78c48dbcda6ff134f2ce3b604f283ddc5e7040c125e406ec573e3f6e7bfcde681fe574b84d7736e114ea7c0b
diff --git a/app-emacs/jinx/jinx-0.9.ebuild b/app-emacs/jinx/jinx-0.9.ebuild
new file mode 100644
index 000000000000..9e53b9cc2c8e
--- /dev/null
+++ b/app-emacs/jinx/jinx-0.9.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+inherit edo elisp toolchain-funcs
+
+DESCRIPTION="Enchanted Spell Checker for GNU Emacs"
+HOMEPAGE="https://github.com/minad/jinx"
+
+# Recompressed from ELPA.
+SRC_URI="https://dev.gentoo.org/~arsen/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-text/enchant:2
+ >=app-emacs/compat-29.1.4.0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+ELISP_REMOVE="${PN}-pkg.el"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ edo $(tc-getCC) -fPIC -Wall -Wextra -shared \
+ $($(tc-getPKG_CONFIG) --cflags --libs enchant-2) \
+ ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} -o jinx-mod.so jinx-mod.c
+ elisp_src_compile
+}
+
+src_install() {
+ elisp-make-autoload-file
+ elisp_src_install
+
+ elisp-modules-install "${PN}" jinx-mod.so
+ doinfo jinx.info
+}