summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-11-01 19:39:51 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-11-01 20:46:45 +0100
commit9061e0556951f986d3e187873d78bf655f894080 (patch)
tree67c0fe1b29eb7aac3c6812f320e6433c3dd0b28d
parentmedia-libs/libmtp: Add missing || die, DOCS to array, sorting (diff)
downloadgentoo-9061e055.tar.gz
gentoo-9061e055.tar.bz2
gentoo-9061e055.zip
media-libs/libmtp: Simplify live proceedings
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--media-libs/libmtp/libmtp-1.1.16.ebuild9
-rw-r--r--media-libs/libmtp/libmtp-9999.ebuild9
2 files changed, 8 insertions, 10 deletions
diff --git a/media-libs/libmtp/libmtp-1.1.16.ebuild b/media-libs/libmtp/libmtp-1.1.16.ebuild
index ab1ccf9d3d55..891ca253c66e 100644
--- a/media-libs/libmtp/libmtp-1.1.16.ebuild
+++ b/media-libs/libmtp/libmtp-1.1.16.ebuild
@@ -24,6 +24,7 @@ RDEPEND="virtual/libusb:1
crypt? ( >=dev-libs/libgcrypt-1.5.4:0= )"
DEPEND="${RDEPEND}"
BDEPEND="
+ >sys-devel/gettext-0.18.3
virtual/pkgconfig
doc? ( app-doc/doxygen )"
@@ -40,12 +41,10 @@ src_prepare() {
rm ChangeLog || die
if [[ ${PV} == 9999* ]]; then
- local crpthf=config.rpath
- local crpthd=/usr/share/gettext/${crpthf}
- if has_version '>sys-devel/gettext-0.18.3' && [[ -e ${crpthd} ]]; then
- cp "${crpthd}" . || die
+ if [[ -e /usr/share/gettext/config.rpath ]]; then
+ cp /usr/share/gettext/config.rpath . || die
else
- touch ${crpthf} || die # This is from upstream autogen.sh
+ touch config.rpath || die # This is from upstream autogen.sh
fi
eautoreconf
fi
diff --git a/media-libs/libmtp/libmtp-9999.ebuild b/media-libs/libmtp/libmtp-9999.ebuild
index ab1ccf9d3d55..54647efd4ca9 100644
--- a/media-libs/libmtp/libmtp-9999.ebuild
+++ b/media-libs/libmtp/libmtp-9999.ebuild
@@ -24,6 +24,7 @@ RDEPEND="virtual/libusb:1
crypt? ( >=dev-libs/libgcrypt-1.5.4:0= )"
DEPEND="${RDEPEND}"
BDEPEND="
+ >sys-devel/gettext-0.18.3
virtual/pkgconfig
doc? ( app-doc/doxygen )"
@@ -40,12 +41,10 @@ src_prepare() {
rm ChangeLog || die
if [[ ${PV} == 9999* ]]; then
- local crpthf=config.rpath
- local crpthd=/usr/share/gettext/${crpthf}
- if has_version '>sys-devel/gettext-0.18.3' && [[ -e ${crpthd} ]]; then
- cp "${crpthd}" . || die
+ if [[ -e crpthd=/usr/share/gettext/config.rpath ]]; then
+ cp crpthd=/usr/share/gettext/config.rpath . || die
else
- touch ${crpthf} || die # This is from upstream autogen.sh
+ touch config.rpath || die # This is from upstream autogen.sh
fi
eautoreconf
fi