summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-30 18:29:46 +0100
committerMichał Górny <mgorny@gentoo.org>2023-10-30 19:04:36 +0100
commit9072d3d663352ef58d990c2fc120151b3388e384 (patch)
tree9e3000cbecd229f4e86396c880f5a8026e55ef13
parentdev-python/pytest-django: Bump to 4.6.0 (diff)
downloadgentoo-9072d3d663352ef58d990c2fc120151b3388e384.tar.gz
gentoo-9072d3d663352ef58d990c2fc120151b3388e384.tar.bz2
gentoo-9072d3d663352ef58d990c2fc120151b3388e384.zip
dev-python/jupyter-core: Bump to 5.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jupyter-core/Manifest1
-rw-r--r--dev-python/jupyter-core/jupyter-core-5.5.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/jupyter-core/Manifest b/dev-python/jupyter-core/Manifest
index 81263ce4d705..35c668c10af4 100644
--- a/dev-python/jupyter-core/Manifest
+++ b/dev-python/jupyter-core/Manifest
@@ -1,3 +1,4 @@
DIST jupyter_core-5.3.1.tar.gz 84448 BLAKE2B 22adc8f7a0b39fa4ffd087a7c7305fa29d05d45200b69a3af6827083183292e58b3b5854b60545eb065808dffec2ae9252feb573b9450bd3014d493cb1784ed3 SHA512 752ce40c0aa71432177100f34596ad98d9907f8e2d26fcabc0bce7b4f5efb9207f1979d2db180f00d2160a84034656952640cde757186e538f7038bb0f626c7b
DIST jupyter_core-5.3.2.tar.gz 84808 BLAKE2B 02442d6c389e88996930e4040dcc0c38040218360831d6768f237fa1bd59e1f06576cab29d7eba960337d491733872a82cf09aed8c147fcc29b3e4909a485d38 SHA512 f202cb16dc5d42d4ae87dd6fd91c3fa38f4b6611b58fd904eb37b647628f6ca5164e4e61d4eb09cc0dee192463ddd7577f64242b1dd7b014fecff5b252f661e1
DIST jupyter_core-5.4.0.tar.gz 85162 BLAKE2B 32d5c50e3b4dbd1a92eb3064d072bd8d70b4a67a7c5828fb249a587f65d200bdce6081252f97276ada625a390f52802c068af8f99f23ae43e69e0fd19697f739 SHA512 2e4d65f07590bd1cad0df7043b6f6542b3fadbdf9a0c4ec699a39725a04c12aeef123917eab445d230d42e779655e797924800fd9d8acd0b9d27060f26b243d2
+DIST jupyter_core-5.5.0.tar.gz 85369 BLAKE2B 41fa2381023c8f2313607d2ac989d1f35dcd362abd4b9573affaf9fc34cd48eb260d2ad68af97be2d47aa4a077f1756e6e291a4f0dd48c9774df2d31dda7e9b4 SHA512 92ca5ddc69d58ecdf1f707104e950ba43c88630991b0a6951fb6ba83260573b9f48c7903b25ae7bc105c08b3179de4bebb5a87b66453b96ceed631cbf555d631
diff --git a/dev-python/jupyter-core/jupyter-core-5.5.0.ebuild b/dev-python/jupyter-core/jupyter-core-5.5.0.ebuild
new file mode 100644
index 000000000000..080478bb011c
--- /dev/null
+++ b/dev-python/jupyter-core/jupyter-core-5.5.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Core common functionality of Jupyter projects"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_core/
+ https://pypi.org/project/jupyter-core/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/platformdirs-2.5[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.11.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/ipython-4.0.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/myst-parser \
+ dev-python/pydata-sphinx-theme \
+ dev-python/sphinx-autodoc-typehints \
+ dev-python/sphinxcontrib-github-alt \
+ dev-python/sphinxcontrib-spelling \
+ dev-python/traitlets
+distutils_enable_tests pytest