summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2023-10-22 00:10:36 +0300
committerMart Raudsepp <leio@gentoo.org>2023-10-22 00:21:38 +0300
commit9078f26231d543b83a3876dc97c2b3dd34a17456 (patch)
tree65ab664fb74cc07606f72fd5279d68a6d661e59c
parentprofiles: package.deprecated: Mark dev-qt/qtscript:5 deprecated (diff)
downloadgentoo-9078f26231d543b83a3876dc97c2b3dd34a17456.tar.gz
gentoo-9078f26231d543b83a3876dc97c2b3dd34a17456.tar.bz2
gentoo-9078f26231d543b83a3876dc97c2b3dd34a17456.zip
media-libs/libshumate: add 1.1.1
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
-rw-r--r--media-libs/libshumate/Manifest1
-rw-r--r--media-libs/libshumate/libshumate-1.1.1.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/media-libs/libshumate/Manifest b/media-libs/libshumate/Manifest
index 718f7253512d..ec70f64a2de0 100644
--- a/media-libs/libshumate/Manifest
+++ b/media-libs/libshumate/Manifest
@@ -1,2 +1,3 @@
DIST libshumate-1.0.5.tar.xz 112008 BLAKE2B e20e53fdcd34aa67853f68d72801e7ef7dfcb39670f67f0bfab76cc04a0dc4e92b614b5a588560de64c85406b63a105b5ba19854cf1189a5a3c03f097c93556e SHA512 73beffb8eea95b279d297294ce96a39883856d280eeda1215b908d5b7ac86aff49bbd9c07065ffb394657497997b1994712de6526efd9076f9a5feb1c17b9532
DIST libshumate-1.1.0.tar.xz 299096 BLAKE2B 111eaca1ed7d0abc9f4bc5d83c10bd84aadd42cf92d3a5ac37e00edd9b433c1db768686c9935f7f88b200c6a2b7c1898b0e96bcf036947bc7097e5ddfcd34d82 SHA512 138736090ad448cd73812e5b3da6d1e9199601ca7ee9b026a19586c680ccb306871fe2a779db4cffde822834974154ccd55117dd58ce849c655fde71dab0237a
+DIST libshumate-1.1.1.tar.xz 299200 BLAKE2B 763bba4c27d2e576b687120fff1d9dd07029307032618e4b629b1a5cd7091d46349cc3908388b84e7053b6e76d11ea0c646edbda2468bee5fc3c8cad874cfe3d SHA512 d39d47d7a41eb692b4f42c66ee4e4c84f028314d6bf8757b7c7803fb67eff72ad2af3b5cb5256b2325f39291df0b1440f64b685e5a98b7c3a3712977ff495c5e
diff --git a/media-libs/libshumate/libshumate-1.1.1.ebuild b/media-libs/libshumate/libshumate-1.1.1.ebuild
new file mode 100644
index 000000000000..0238d92667b6
--- /dev/null
+++ b/media-libs/libshumate/libshumate-1.1.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson vala virtualx
+
+DESCRIPTION="Shumate is a GTK toolkit providing widgets for embedded maps"
+HOMEPAGE="https://wiki.gnome.org/Projects/libshumate https://gitlab.gnome.org/GNOME/libshumate"
+
+SLOT="1.0/1"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~sparc ~x86"
+REQUIRED_USE="gtk-doc? ( introspection )"
+
+IUSE="gtk-doc +introspection sysprof vala" # vector-renderer is still experimental, maybe put in at a later release
+
+RDEPEND="
+ >=dev-libs/glib-2.68.0:2
+ >=x11-libs/cairo-1.4
+ >=dev-db/sqlite-1.12:3
+ >=gui-libs/gtk-4:4
+ >=net-libs/libsoup-3.0:3.0
+ introspection? ( >=dev-libs/gobject-introspection-0.6.3:= )
+"
+# vector-renderer? (
+# >=dev-libs/json-glib-1.6.0[introspection?]
+# dev-libs/protobuf-c
+# )
+
+DEPEND="${RDEPEND}
+ sysprof? ( dev-util/sysprof-capture:4 )
+"
+BDEPEND="
+ gtk-doc? ( >=dev-util/gi-docgen-2021.1 )
+ vala? ( $(vala_depend) )
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use introspection gir)
+ $(meson_use vala vapi)
+ $(meson_use gtk-doc gtk_doc)
+ -Ddemos=false # only built, not installed
+ # $(meson_use vector-renderer vector_renderer)
+ -Dvector_renderer=false
+ -Dlibsoup3=true
+ $(meson_feature sysprof)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx dbus-run-session meson test -C "${BUILD_DIR}" || die 'tests failed'
+}
+
+src_install() {
+ meson_src_install
+ if use gtk-doc; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/html || die
+ mv "${ED}"/usr/share/doc/libshumate-1.0 "${ED}"/usr/share/gtk-doc/html/libshumate-1.0 || die
+ fi
+}