summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2024-04-26 15:03:19 +0200
committerFlorian Schmaus <flow@gentoo.org>2024-04-30 10:15:20 +0200
commit907e8457f31775648ccee6eb0f03277ea9b00799 (patch)
tree4a995cc48ff5d0cb814abcd6b6f8cb5098d6c401
parentdev-lang/mozart: restrict to <=virtual/jdk-17:* (diff)
downloadgentoo-907e8457f31775648ccee6eb0f03277ea9b00799.tar.gz
gentoo-907e8457f31775648ccee6eb0f03277ea9b00799.tar.bz2
gentoo-907e8457f31775648ccee6eb0f03277ea9b00799.zip
dev-lang/scala: fix compilation errors
- Replaces ${SBT_PVR} with ${SBTV} for #904316 - Restricts to <=virtual/jdk-17:* for #854717 - Switches from ant-core to >=dev-java/ant-1.10.14-r3 - Updates EAPI 7 -> 8 Closes: https://bugs.gentoo.org/854717 Closes: https://bugs.gentoo.org/904316 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/36474 Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--dev-lang/scala/scala-2.12.10-r1.ebuild (renamed from dev-lang/scala/scala-2.12.10.ebuild)17
1 files changed, 6 insertions, 11 deletions
diff --git a/dev-lang/scala/scala-2.12.10.ebuild b/dev-lang/scala/scala-2.12.10-r1.ebuild
index dc6558800069..3ce6719026ac 100644
--- a/dev-lang/scala/scala-2.12.10.ebuild
+++ b/dev-lang/scala/scala-2.12.10-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI=8
JAVA_PKG_IUSE="doc source"
@@ -52,7 +52,7 @@ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
IUSE="binary emacs"
-COMMON_DEP="dev-java/ant-core:0
+COMMON_DEP=">=dev-java/ant-1.10.14-r3:0
dev-java/jline:2"
DEPEND="${COMMON_DEP}
@@ -60,7 +60,7 @@ DEPEND="${COMMON_DEP}
>=dev-java/sbt-${SBTV}:0
media-gfx/graphviz
)
- >=virtual/jdk-1.8:*
+ <=virtual/jdk-17:*
app-arch/xz-utils:0"
RDEPEND="${COMMON_DEP}
@@ -100,7 +100,7 @@ src_unpack() {
}
src_prepare() {
- java-pkg_getjars ant-core,jline-2,sbt
+ java-pkg_getjars ant,jline-2,sbt
if ! use binary; then
local a
@@ -117,16 +117,11 @@ src_prepare() {
# gentoo patch (by gienah) to stop it calling git log in the build
eapply "${FILESDIR}/${PN}-2.12.10-no-git.patch"
- local SBT_PVR="$(java-config --query=PVR --package=sbt)"
- sed -e "s@sbt.version=${SBTV}@sbt.version=${SBT_PVR}@" \
- -i "${S}/project/build.properties" \
- || die "Could not set sbt.version=${SBT_PVR} in project/build.properties"
-
cat <<- EOF > "${S}/sbt"
#!/bin/bash
gjl_package=sbt
gjl_jar="sbt-launch.jar"
- gjl_java_args="-Dsbt.version=${SBT_PVR} -Xms512M -Xmx1536M -Xss1M -XX:+CMSClassUnloadingEnabled -Duser.home="${WORKDIR}""
+ gjl_java_args="-Dsbt.version=${SBTV} -Xms512M -Xmx1536M -Xss1M -XX:+CMSClassUnloadingEnabled -Duser.home="${WORKDIR}""
source "${EPREFIX}"/usr/share/java-config-2/launcher/launcher.bash
EOF
chmod u+x "${S}/sbt" || die