summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-29 07:10:44 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-29 07:51:24 +0200
commit9089cd9a5978df3c70afe2223f7ee6fcdfd93613 (patch)
treecb266a2d887ee59771442884adc1ffccec994546
parentapp-admin/awscli: Bump to 1.20.9 (diff)
downloadgentoo-9089cd9a5978df3c70afe2223f7ee6fcdfd93613.tar.gz
gentoo-9089cd9a5978df3c70afe2223f7ee6fcdfd93613.tar.bz2
gentoo-9089cd9a5978df3c70afe2223f7ee6fcdfd93613.zip
dev-python/pylint: Bump to 2.9.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pylint/Manifest1
-rw-r--r--dev-python/pylint/pylint-2.9.6.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index 3d1653ded47d..3ab1c52bfe64 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -4,3 +4,4 @@ DIST pylint-2.9.1.gh.tar.gz 769124 BLAKE2B feabb520c22722df73471e87e05f22f0fb937
DIST pylint-2.9.3.gh.tar.gz 770364 BLAKE2B 3892286ffbd79b417c6decba44bce97f45192299ac8e2ec0e24770b2dd6cf1c28bac790626a478d47a6124ec0470ea9fc0d4230c5a1e807532852844445bb95a SHA512 45c037b970b66254b54a4810a5609dc098b5493d409826333e6a75f9ff0fc02921162711d88c45fd2f437e6521f639c33b25b714830a977c501612ee497501bb
DIST pylint-2.9.4.gh.tar.gz 777252 BLAKE2B 84bc535b3c471be5d01a02ee67494d993cc257f0938e1bb0e35b1d64415d256c4f0dabd45cdc3319716c67e5e71ea935b63633f56b97013bd8616296343709d5 SHA512 9b5db20cf2d858e662c309b11cf28bf247b7c5f90de4f747733a0288ff4acced02e0e6b83145e7d940772eb9debf297b9ee6976e0f3ffbd73aaacaa3f4cb51e6
DIST pylint-2.9.5.gh.tar.gz 778090 BLAKE2B cbcf5427665f56cc37afd08fb537fcc3f17697ca7cdbd7da97bad4093f344c9b961a156f5d141e070fa84c7e07293175a70585a8c996c9cffb7cef80717752af SHA512 84695bae88704391752f4b0944e39f5b44933fee8d88a8839729845b93bbe59876da08ab98645217c4ff2a98fd793a92063123b25a595fb332ce0a3943bcf7e7
+DIST pylint-2.9.6.gh.tar.gz 779390 BLAKE2B b1d8794e1e7ccdde87919eb943f83287c0a7b85b67f3722cbbe68887f2c61ab30b354548e25b70c661234647e35f79beb6aaad5f6be6bfde8c2475cf03676922 SHA512 a23ff089853398df2e4232767ca87c21e4ab4fc6805de80db796c78c56e0da1ade9b0586f5c14a98524bf607e0d240c354cf63287eec7dfdce263188eb19ddce
diff --git a/dev-python/pylint/pylint-2.9.6.ebuild b/dev-python/pylint/pylint-2.9.6.ebuild
new file mode 100644
index 000000000000..75d26e73965e
--- /dev/null
+++ b/dev-python/pylint/pylint-2.9.6.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python code static checker"
+HOMEPAGE="https://www.logilab.org/project/pylint
+ https://pypi.org/project/pylint/
+ https://github.com/pycqa/pylint/"
+SRC_URI="
+ https://github.com/pycqa/pylint/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="examples"
+
+RDEPEND="
+ <dev-python/astroid-2.7[${PYTHON_USEDEP}]
+ >=dev-python/astroid-2.6.5[${PYTHON_USEDEP}]
+ >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
+ <dev-python/isort-6[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.7[${PYTHON_USEDEP}]
+ >=dev-python/toml-0.7.1[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.4.4-sphinx-theme.patch"
+)
+
+distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests pytest
+
+python_test() {
+ local skipped_tests=(
+ # No need to run the benchmarks
+ tests/benchmark/test_baseline_benchmarks.py
+ )
+ # Specify the test directory explicitly to avoid import file mismatches
+ epytest tests ${skipped_tests[@]/#/--deselect }
+}
+
+python_install_all() {
+ if use examples ; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto examples
+ dodoc -r examples/.
+ fi
+
+ distutils-r1_python_install_all
+}