summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-29 15:46:13 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-29 15:53:31 +0100
commit909353d9b103262c47f433d53c6252ffce801373 (patch)
tree8801c5132e99274691536c47f7461d5a8055ffdf
parentdev-python/sybil: Add a fix for pytest-8 (diff)
downloadgentoo-909353d9.tar.gz
gentoo-909353d9.tar.bz2
gentoo-909353d9.zip
dev-python/pytest-lazy-fixture: Require <dev-python/pytest-8
Bug: https://github.com/TvoroG/pytest-lazy-fixture/issues/65 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-lazy-fixture/pytest-lazy-fixture-0.6.3-r1.ebuild (renamed from dev-python/pytest-lazy-fixture/pytest-lazy-fixture-0.6.3.ebuild)14
1 files changed, 10 insertions, 4 deletions
diff --git a/dev-python/pytest-lazy-fixture/pytest-lazy-fixture-0.6.3.ebuild b/dev-python/pytest-lazy-fixture/pytest-lazy-fixture-0.6.3-r1.ebuild
index 7088080bf410..500904a50a46 100644
--- a/dev-python/pytest-lazy-fixture/pytest-lazy-fixture-0.6.3.ebuild
+++ b/dev-python/pytest-lazy-fixture/pytest-lazy-fixture-0.6.3-r1.ebuild
@@ -1,20 +1,26 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
inherit distutils-r1 pypi
DESCRIPTION="It helps to use fixtures in pytest.mark.parametrize"
-HOMEPAGE="https://github.com/tvorog/pytest-lazy-fixture"
+HOMEPAGE="
+ https://github.com/tvorog/pytest-lazy-fixture/
+ https://pypi.org/project/pytest-lazy-fixture/
+"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~mips ppc64 ~riscv ~s390 sparc x86"
-RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+RDEPEND="
+ <dev-python/pytest-8[${PYTHON_USEDEP}]
+"
distutils_enable_tests pytest