summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2020-05-10 10:17:17 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-10 13:41:35 +0200
commit90c288ba534fba4d22130514387eca740151aa95 (patch)
tree7eb1f00f077e2205b126ade7c50ca48123677074
parentmedia-video/obs-studio: fix build with GCC-10 (diff)
downloadgentoo-90c288ba.tar.gz
gentoo-90c288ba.tar.bz2
gentoo-90c288ba.zip
media-video/obs-studio: remove version 24.0.5
Closes: https://bugs.gentoo.org/708628 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--media-video/obs-studio/Manifest1
-rw-r--r--media-video/obs-studio/obs-studio-24.0.5.ebuild132
2 files changed, 0 insertions, 133 deletions
diff --git a/media-video/obs-studio/Manifest b/media-video/obs-studio/Manifest
index 1116b91bf0a9..aa70deb5fcb8 100644
--- a/media-video/obs-studio/Manifest
+++ b/media-video/obs-studio/Manifest
@@ -1,2 +1 @@
-DIST obs-studio-24.0.5.tar.gz 7901198 BLAKE2B 79c9712f3523114a70e0df3e0631c19067fd7ead5fd9031123dd4c82d9b92dee69473fb51a495f938430540505a5cf45258eeee01d61a7aaa6654255fee14aca SHA512 99be46046b70597474f25a85036ebe5a2f704eef47c77bc27e2ba8890b877da346ff6008c5922d7a83a4cead9df7214c6a3be885430693e609a42d9d06fedfaf
DIST obs-studio-25.0.8.tar.gz 9531713 BLAKE2B 4775ca8305e1beee4d926eff728351b699ca4d52f66e53409dbcfe1f73699df0286fadc0c138cb76b8eb73e70a143719e46f030b6d15d43629bdcbf23bdb88af SHA512 a97c03dc218a4e03e48f6a7dc82b4a59ebeee2039f17be66bb847681ce9ff3d25e6e015be4af78fe44739f6fad5089b6e683d7657c2e4fde8e547df9a2594a08
diff --git a/media-video/obs-studio/obs-studio-24.0.5.ebuild b/media-video/obs-studio/obs-studio-24.0.5.ebuild
deleted file mode 100644
index 80a9b245d34a..000000000000
--- a/media-video/obs-studio/obs-studio-24.0.5.ebuild
+++ /dev/null
@@ -1,132 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-CMAKE_REMOVE_MODULES_LIST=( FindFreetype )
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit cmake-utils python-single-r1 xdg-utils
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/obsproject/obs-studio.git"
- EGIT_SUBMODULES=()
-else
- SRC_URI="https://github.com/obsproject/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="Software for Recording and Streaming Live Video Content"
-HOMEPAGE="https://obsproject.com"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="+alsa fdk imagemagick jack luajit nvenc pulseaudio python speex +ssl truetype v4l vlc"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-BDEPEND="
- luajit? ( dev-lang/swig )
- python? ( dev-lang/swig )
-"
-DEPEND="
- >=dev-libs/jansson-2.5
- dev-qt/qtcore:5
- dev-qt/qtdeclarative:5
- dev-qt/qtgui:5
- dev-qt/qtmultimedia:5
- dev-qt/qtnetwork:5
- dev-qt/qtquickcontrols:5
- dev-qt/qtsql:5
- dev-qt/qtsvg:5
- dev-qt/qtwidgets:5
- dev-qt/qtx11extras:5
- media-video/ffmpeg:=[x264]
- net-misc/curl
- x11-libs/libXcomposite
- x11-libs/libXinerama
- x11-libs/libXrandr
- alsa? ( media-libs/alsa-lib )
- fdk? ( media-libs/fdk-aac:= )
- imagemagick? ( media-gfx/imagemagick:= )
- jack? ( virtual/jack )
- luajit? ( dev-lang/luajit:2 )
- nvenc? (
- || (
- <media-video/ffmpeg-4[nvenc]
- >=media-video/ffmpeg-4[video_cards_nvidia]
- )
- )
- pulseaudio? ( media-sound/pulseaudio )
- python? ( ${PYTHON_DEPS} )
- speex? ( media-libs/speexdsp )
- ssl? ( net-libs/mbedtls:= )
- truetype? (
- media-libs/fontconfig
- media-libs/freetype
- )
- v4l? ( media-libs/libv4l )
- vlc? ( media-video/vlc:= )
-"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_configure() {
- local libdir=$(get_libdir)
- local mycmakeargs=(
- -DDISABLE_ALSA=$(usex !alsa)
- -DDISABLE_FREETYPE=$(usex !truetype)
- -DDISABLE_JACK=$(usex !jack)
- -DDISABLE_LIBFDK=$(usex !fdk)
- -DDISABLE_PULSEAUDIO=$(usex !pulseaudio)
- -DDISABLE_SPEEXDSP=$(usex !speex)
- -DDISABLE_V4L2=$(usex !v4l)
- -DDISABLE_VLC=$(usex !vlc)
- -DLIBOBS_PREFER_IMAGEMAGICK=$(usex imagemagick)
- -DOBS_MULTIARCH_SUFFIX=${libdir#lib}
- -DOBS_VERSION_OVERRIDE=${PV}
- -DUNIX_STRUCTURE=1
- -DWITH_RTMPS=$(usex ssl)
- )
-
- if use luajit || use python; then
- mycmakeargs+=(
- -DDISABLE_LUA=$(usex !luajit)
- -DDISABLE_PYTHON=$(usex !python)
- -DENABLE_SCRIPTING=yes
- )
- else
- mycmakeargs+=( -DENABLE_SCRIPTING=no )
- fi
-
- cmake-utils_src_configure
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
-
- if ! use alsa && ! use pulseaudio; then
- elog
- elog "For the audio capture features to be available,"
- elog "either the 'alsa' or the 'pulseaudio' USE-flag needs to"
- elog "be enabled."
- elog
- fi
-
- if ! has_version "sys-apps/dbus"; then
- elog
- elog "The 'sys-apps/dbus' package is not installed, but"
- elog "could be used for disabling hibernating, screensaving,"
- elog "and sleeping. Where it is not installed,"
- elog "'xdg-screensaver reset' is used instead"
- elog "(if 'x11-misc/xdg-utils' is installed)."
- elog
- fi
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}