summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@gentoo.org>2024-04-17 09:56:32 +0200
committerPetr Vaněk <arkamar@gentoo.org>2024-04-17 09:59:27 +0200
commit90d226de6d0cb6f0e9bc12b45ff6724c3845dd5a (patch)
tree8c9ced7a2403f04708f0679a910b1469b7ae3978
parentdev-lang/execline: add 2.9.5.1 (diff)
downloadgentoo-90d226de6d0cb6f0e9bc12b45ff6724c3845dd5a.tar.gz
gentoo-90d226de6d0cb6f0e9bc12b45ff6724c3845dd5a.tar.bz2
gentoo-90d226de6d0cb6f0e9bc12b45ff6724c3845dd5a.zip
sys-apps/s6: add 2.12.0.4
Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
-rw-r--r--sys-apps/s6/Manifest1
-rw-r--r--sys-apps/s6/s6-2.12.0.4.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/sys-apps/s6/Manifest b/sys-apps/s6/Manifest
index aeaf57560d97..1ad9b30254dc 100644
--- a/sys-apps/s6/Manifest
+++ b/sys-apps/s6/Manifest
@@ -1 +1,2 @@
DIST s6-2.12.0.3.tar.gz 255368 BLAKE2B 2d30b327d45f0cd803cfff1b649b8393d54ff32eb545b536f17d74abca9f5a5638fdea26a5c015756d45ad48201b4adc7479b6cfd7c3f8957693fc3018127c00 SHA512 ecc57b5a06fb413d74337324f8942c905075cf14d87c1471568a836c747271cf95d0edecac69dea54cee55f7a3dbd102493876356c2d36065ab35962b87b559a
+DIST s6-2.12.0.4.tar.gz 255314 BLAKE2B 4a7da37affdc2d0651da905fdfbffe897709cc6f2a4a36453f0a87c88da66adb307805b9f8c850813186ce51c18ed07b8a95aa34a8a266a5a24b3b8646b19485 SHA512 dfdb9c0189177762a89d1f47e1d6b0a82bba5554baef4fa899b1c0a85c192d5e1dac2b929173d750df3707f0d699b28591f1eab3e63b8791e4a51af1c65e3e56
diff --git a/sys-apps/s6/s6-2.12.0.4.ebuild b/sys-apps/s6/s6-2.12.0.4.ebuild
new file mode 100644
index 000000000000..721d293067ea
--- /dev/null
+++ b/sys-apps/s6/s6-2.12.0.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature toolchain-funcs
+
+DESCRIPTION="skarnet.org's small and secure supervision software suite"
+HOMEPAGE="https://www.skarnet.org/software/s6/"
+SRC_URI="https://www.skarnet.org/software/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~mips ~riscv ~x86"
+IUSE="+execline"
+
+RDEPEND="
+ >=dev-libs/skalibs-2.14.1.0:=
+ execline? ( dev-lang/execline:= )
+"
+DEPEND="${RDEPEND}"
+
+HTML_DOCS=( doc/. )
+
+src_prepare() {
+ default
+
+ # Avoid QA warning for LDFLAGS addition
+ sed -i -e 's/.*-Wl,--hash-style=both$/:/' configure || die
+
+ sed -i -e '/AR := /d' -e '/RANLIB := /d' Makefile || die
+}
+
+src_configure() {
+ tc-export AR CC RANLIB
+
+ local myconf=(
+ --bindir=/bin
+ --dynlibdir="/$(get_libdir)"
+ --libdir="/usr/$(get_libdir)/${PN}"
+ --libexecdir=/lib/s6
+ --with-dynlib="/$(get_libdir)"
+ --with-lib="/usr/$(get_libdir)/execline"
+ --with-lib="/usr/$(get_libdir)/skalibs"
+ --with-sysdeps="/usr/$(get_libdir)/skalibs"
+ --enable-shared
+ --disable-allstatic
+ --disable-static
+ --disable-static-libc
+ $(use_enable execline)
+ )
+
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ optfeature "man pages" app-doc/s6-man-pages
+}