summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-10-04 15:21:54 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-10-04 16:59:06 -0400
commit90e2ade895713daafca597a34e29c070aee7a36c (patch)
tree32c53f4c9d884d6cc510c766e38d917631a8a6dd
parentwww-client/chromium: fix building without AVX2 (diff)
downloadgentoo-90e2ade8.tar.gz
gentoo-90e2ade8.tar.bz2
gentoo-90e2ade8.zip
media-libs/smpeg: drop 0.4.4-r10
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--media-libs/smpeg/smpeg-0.4.4-r10.ebuild75
1 files changed, 0 insertions, 75 deletions
diff --git a/media-libs/smpeg/smpeg-0.4.4-r10.ebuild b/media-libs/smpeg/smpeg-0.4.4-r10.ebuild
deleted file mode 100644
index 410c6a7db189..000000000000
--- a/media-libs/smpeg/smpeg-0.4.4-r10.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools epatch flag-o-matic multilib-minimal
-
-DESCRIPTION="SDL MPEG Player Library"
-HOMEPAGE="https://icculus.org/smpeg/"
-SRC_URI="ftp://ftp.lokigames.com/pub/open-source/smpeg/${P}.tar.gz
- mirror://gentoo/${P}-gtkm4.patch.bz2"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="X debug cpu_flags_x86_mmx opengl static-libs"
-
-RDEPEND="
- >=media-libs/libsdl-1.2.15-r4[${MULTILIB_USEDEP}]
- opengl? (
- >=virtual/glu-9.0-r1[${MULTILIB_USEDEP}]
- >=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}]
- )
- X? (
- >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
- >=x11-libs/libXi-1.7.2[${MULTILIB_USEDEP}]
- >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
- )"
-DEPEND="${RDEPEND}"
-
-DOCS=( CHANGES README README.SDL_mixer TODO )
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-m4.patch \
- "${FILESDIR}"/${P}-gnu-stack.patch \
- "${FILESDIR}"/${P}-config.patch \
- "${FILESDIR}"/${P}-PIC.patch \
- "${FILESDIR}"/${P}-gcc41.patch \
- "${FILESDIR}"/${P}-flags.patch \
- "${FILESDIR}"/${P}-automake.patch \
- "${FILESDIR}"/${P}-mmx.patch \
- "${FILESDIR}"/${P}-malloc.patch \
- "${FILESDIR}"/${P}-format.patch \
- "${FILESDIR}"/${P}-missing-init.patch \
- "${FILESDIR}"/${P}-gcc6.patch
-
- cd "${WORKDIR}"
- epatch "${DISTDIR}"/${P}-gtkm4.patch.bz2
- rm "${S}/acinclude.m4"
-
- cd "${S}"
- mv configure.in configure.ac || die
- AT_M4DIR="${S}/m4" eautoreconf
-}
-
-multilib_src_configure() {
- [[ ${CHOST} == *-solaris* ]] && append-libs -lnsl -lsocket
-
- # the debug option is bogus ... all it does is add extra
- # optimizations if you pass --disable-debug
- ECONF_SOURCE="${S}" econf \
- --enable-debug \
- --disable-gtk-player \
- $(use_enable static-libs static) \
- $(use_enable debug assertions) \
- $(use_with X x) \
- $(use_enable opengl opengl-player) \
- $(use_enable cpu_flags_x86_mmx mmx)
-}
-
-multilib_src_install_all() {
- if ! use static-libs; then
- find "${ED}" -name '*.la' -delete || die
- fi
-}