summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-09-30 15:45:44 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-09-30 15:55:46 +0200
commit90f1aaf7c30d956bc606d002b7fdafb701c03d1c (patch)
treed87ae874dee0162ea2d93815148398f786395455
parentdev-ros/ament_copyright: fix setuptools dep (diff)
downloadgentoo-90f1aaf7c30d956bc606d002b7fdafb701c03d1c.tar.gz
gentoo-90f1aaf7c30d956bc606d002b7fdafb701c03d1c.tar.bz2
gentoo-90f1aaf7c30d956bc606d002b7fdafb701c03d1c.zip
dev-ros/ament_cppcheck: fix setuptools dep
Closes: https://bugs.gentoo.org/745714 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--dev-ros/ament_cppcheck/Manifest1
-rw-r--r--dev-ros/ament_cppcheck/ament_cppcheck-0.10.0.ebuild1
-rw-r--r--dev-ros/ament_cppcheck/ament_cppcheck-0.9.5.ebuild37
-rw-r--r--dev-ros/ament_cppcheck/ament_cppcheck-9999.ebuild1
4 files changed, 2 insertions, 38 deletions
diff --git a/dev-ros/ament_cppcheck/Manifest b/dev-ros/ament_cppcheck/Manifest
index 8dd9c04fcb27..2bd08ffb898e 100644
--- a/dev-ros/ament_cppcheck/Manifest
+++ b/dev-ros/ament_cppcheck/Manifest
@@ -1,2 +1 @@
DIST ament_lint-0.10.0.tar.gz 219525 BLAKE2B 6ba7a32d0678e545c24b74ed187991140c34a363ad855e469f0e20f8a088b7cc939bbd187566233e099576e4c2b899d7d75edf311d3026234222078968be7ce6 SHA512 565413fa325317e6f00ce18051eb13556d1d50144d2c8f62368e5505455ef7f9fae3a69e8d723a3949e44b1f9e638741ae6d9b87687df81a661eb804365200f8
-DIST ament_lint-0.9.5.tar.gz 218077 BLAKE2B bc49fdb517bcdab815cfd4c945e9d61a9b53d4b600361ced9161b6186bfb74fdb3d5ed5f14a48f22a91fd0737333dc76cc7d55044c204ea864b53dd68e32254b SHA512 1c5b3acb31a07f4613e13fe69f6dad1981df0dc596e46a07651322a4da1c5f3db40befb775aa42aabc1f6808132c950c9f37950f64b4196e3c1b40871e25a384
diff --git a/dev-ros/ament_cppcheck/ament_cppcheck-0.10.0.ebuild b/dev-ros/ament_cppcheck/ament_cppcheck-0.10.0.ebuild
index 6a0744a992d3..42fa61df3e0b 100644
--- a/dev-ros/ament_cppcheck/ament_cppcheck-0.10.0.ebuild
+++ b/dev-ros/ament_cppcheck/ament_cppcheck-0.10.0.ebuild
@@ -4,6 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python{3_7,3_8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
diff --git a/dev-ros/ament_cppcheck/ament_cppcheck-0.9.5.ebuild b/dev-ros/ament_cppcheck/ament_cppcheck-0.9.5.ebuild
deleted file mode 100644
index 6a0744a992d3..000000000000
--- a/dev-ros/ament_cppcheck/ament_cppcheck-0.9.5.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 2019-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{3_7,3_8} )
-
-inherit distutils-r1
-
-ROS_PN="ament_lint"
-if [ "${PV#9999}" != "${PV}" ] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/ament/ament_lint"
- SRC_URI=""
- S=${WORKDIR}/${P}/${PN}
-else
- SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
- S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
-fi
-
-DESCRIPTION="The ability to perform static code analysis on C/C++ code using Cppcheck"
-HOMEPAGE="https://github.com/ament/ament_lint"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-if [ "${PV#9999}" != "${PV}" ] ; then
- KEYWORDS=""
-else
- KEYWORDS="~amd64"
-fi
-IUSE=""
-
-RDEPEND="
- dev-util/cppcheck
-"
-DEPEND=""
-BDEPEND=""
diff --git a/dev-ros/ament_cppcheck/ament_cppcheck-9999.ebuild b/dev-ros/ament_cppcheck/ament_cppcheck-9999.ebuild
index 6a0744a992d3..42fa61df3e0b 100644
--- a/dev-ros/ament_cppcheck/ament_cppcheck-9999.ebuild
+++ b/dev-ros/ament_cppcheck/ament_cppcheck-9999.ebuild
@@ -4,6 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python{3_7,3_8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1