summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-11-17 11:17:36 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-17 11:17:36 +0100
commit90f227d0c692f72c54d3983260b942a8d0474194 (patch)
tree1aa5b3b1311361da33bfa5cc570f392a9469b8a3
parentx11-wm/i3: Use meson_src_install explicitly (diff)
downloadgentoo-90f227d0c692f72c54d3983260b942a8d0474194.tar.gz
gentoo-90f227d0c692f72c54d3983260b942a8d0474194.tar.bz2
gentoo-90f227d0c692f72c54d3983260b942a8d0474194.zip
sci-libs/buddy: Port to EAPI 7
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--sci-libs/buddy/buddy-2.4-r1.ebuild21
1 files changed, 13 insertions, 8 deletions
diff --git a/sci-libs/buddy/buddy-2.4-r1.ebuild b/sci-libs/buddy/buddy-2.4-r1.ebuild
index c5dfddbbe1e1..004107ea6cf6 100644
--- a/sci-libs/buddy/buddy-2.4-r1.ebuild
+++ b/sci-libs/buddy/buddy-2.4-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit fortran-2
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="buddy"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="doc examples static-libs"
+IUSE="doc examples"
DOCS=( doc/tech.txt )
PATCHES=(
@@ -21,16 +21,21 @@ PATCHES=(
)
src_configure() {
- econf $(use_enable static-libs static)
+ econf --disable-static
}
src_install() {
default
-
- use doc && docinto ps && dodoc doc/*.ps
+ find "${ED}" -name '*.la' -delete || die
if use examples; then
- insinto /usr/share/${PN}/
- doins -r examples
+ find examples/ -name 'Makefile*' -delete || die
+
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ if use doc; then
+ docinto ps
+ dodoc doc/*.ps
fi
}