summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2024-04-07 16:23:52 +0100
committerMarek Szuba <marecki@gentoo.org>2024-04-07 19:26:17 +0100
commit90fcce3361d1dca99f2cb9a4d895d9686b00e1c5 (patch)
treeab139090ca12c5441a57ec00181bf5741f74209e
parentdev-java/openjdk: add x86 bootstrap tarball for SLOT=8 (diff)
downloadgentoo-90fcce3361d1dca99f2cb9a4d895d9686b00e1c5.tar.gz
gentoo-90fcce3361d1dca99f2cb9a4d895d9686b00e1c5.tar.bz2
gentoo-90fcce3361d1dca99f2cb9a4d895d9686b00e1c5.zip
x11-misc/i3lock: add 2.15
Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--x11-misc/i3lock/Manifest1
-rw-r--r--x11-misc/i3lock/i3lock-2.15.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/x11-misc/i3lock/Manifest b/x11-misc/i3lock/Manifest
index d497d592cb07..963a57ad07c0 100644
--- a/x11-misc/i3lock/Manifest
+++ b/x11-misc/i3lock/Manifest
@@ -1 +1,2 @@
DIST i3lock-2.14.1.tar.xz 28756 BLAKE2B b38a3fafeebb5f8cebb643baeb875922659b556a5f919c2a837923e45e8f91a5f3ce297a424414ec9f05255e5888b91723617d837e5ffdbdf81aded42edc34cb SHA512 63b6bd73f66654fe52639434f7d3da64006144ec2ed685ba8683186730d4cc2c10d5aa66174f965030030243f59afaf6def3ff732f710ae441410218f84d6deb
+DIST i3lock-2.15.tar.xz 29100 BLAKE2B e84622e34a54681e162a3012c21fea4cc8b93a66e466647d65cc85f1a874d2be4d9988d54db74165b3dd1eccca1ca257a74b64ddbce08d681c9fc1c78701ee88 SHA512 6079f5233c0820c6e38f3cd8f3732d585e95e7d670408e4fb18ab580a2e1face8f3d6ea13eaaeedc8671f74def917183667e736b35306bf7c630d40625b41ac2
diff --git a/x11-misc/i3lock/i3lock-2.15.ebuild b/x11-misc/i3lock/i3lock-2.15.ebuild
new file mode 100644
index 000000000000..512d70eb36e7
--- /dev/null
+++ b/x11-misc/i3lock/i3lock-2.15.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Simple screen locker"
+HOMEPAGE="https://i3wm.org/i3lock/"
+SRC_URI="https://i3wm.org/${PN}/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-libs/libev
+ sys-libs/pam
+ x11-libs/cairo[X,xcb(+)]
+ x11-libs/libxcb
+ x11-libs/libxkbcommon[X]
+ x11-libs/xcb-util
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-xrm"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ sed -i -e 's:login:system-auth:g' pam/${PN} || die
+}