summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-05-16 15:12:05 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-05-16 16:43:51 +0200
commit910ad0a1efd617cbff83778955285678fb44e58d (patch)
tree61b5b0a90061889648d88c16c93cc2ba6425ac0b
parentsys-libs/pwdb: Drop 0.62-r1, EAPI5-- (diff)
downloadgentoo-910ad0a1efd617cbff83778955285678fb44e58d.tar.gz
gentoo-910ad0a1efd617cbff83778955285678fb44e58d.tar.bz2
gentoo-910ad0a1efd617cbff83778955285678fb44e58d.zip
sys-apps/dmapi: EAPI-7 bump, fix installed docs
Closes: https://bugs.gentoo.org/732042 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--sys-apps/dmapi/dmapi-2.2.12-r2.ebuild50
-rw-r--r--sys-apps/dmapi/files/dmapi-2.2.12-no-doc.patch20
2 files changed, 70 insertions, 0 deletions
diff --git a/sys-apps/dmapi/dmapi-2.2.12-r2.ebuild b/sys-apps/dmapi/dmapi-2.2.12-r2.ebuild
new file mode 100644
index 000000000000..09a877413747
--- /dev/null
+++ b/sys-apps/dmapi/dmapi-2.2.12-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal usr-ldscript
+
+DESCRIPTION="XFS data management API library"
+HOMEPAGE="https://xfs.wiki.kernel.org/"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/cmd_tars/${P}.tar.gz
+ ftp://oss.sgi.com/projects/xfs/previous/cmd_tars/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86"
+IUSE="static-libs"
+
+RDEPEND="sys-fs/xfsprogs"
+DEPEND="${RDEPEND}"
+
+DOCS=( doc/{CHANGES,PORTING} README )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-headers.patch
+ "${FILESDIR}"/${P}-no-doc.patch # bug 732042
+)
+
+src_prepare() {
+ default
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ export OPTIMIZER=${CFLAGS}
+ export DEBUG=-DNDEBUG
+
+ econf \
+ --libexecdir=/usr/$(get_libdir) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install install-dev
+ gen_usr_ldscript -a dm
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/sys-apps/dmapi/files/dmapi-2.2.12-no-doc.patch b/sys-apps/dmapi/files/dmapi-2.2.12-no-doc.patch
new file mode 100644
index 000000000000..295bdb7c6572
--- /dev/null
+++ b/sys-apps/dmapi/files/dmapi-2.2.12-no-doc.patch
@@ -0,0 +1,20 @@
+--- a/Makefile
++++ b/Makefile
+@@ -19,7 +19,7 @@
+ libtool include/builddefs
+
+ LIB_SUBDIRS = include libdm
+-TOOL_SUBDIRS = m4 man doc debian build
++TOOL_SUBDIRS = m4 man debian build
+
+ SUBDIRS = $(LIB_SUBDIRS) $(TOOL_SUBDIRS)
+
+@@ -66,7 +66,7 @@
+ touch .census
+
+ install: default $(addsuffix -install,$(SUBDIRS))
+-ifneq ($(PKG_DISTRIBUTION), debian)
++ifdef false
+ $(INSTALL) -m 755 -d $(PKG_DOC_DIR)
+ $(INSTALL) -m 644 README $(PKG_DOC_DIR)
+ endif