summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-10 15:44:40 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-10 16:04:29 +0200
commit91148bb7326bdb22d41214e0d3ad960b69eed45c (patch)
treef2b244295c77bc6204021b731349f50b66a2c14a
parentdev-python/openapi-core: Bump to 0.16.1 (diff)
downloadgentoo-91148bb7326bdb22d41214e0d3ad960b69eed45c.tar.gz
gentoo-91148bb7326bdb22d41214e0d3ad960b69eed45c.tar.bz2
gentoo-91148bb7326bdb22d41214e0d3ad960b69eed45c.zip
dev-python/astroid: Bump to 2.12.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/astroid/Manifest1
-rw-r--r--dev-python/astroid/astroid-2.12.11.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/astroid/Manifest b/dev-python/astroid/Manifest
index 1eaa4dc98fd4..d0eb7209297b 100644
--- a/dev-python/astroid/Manifest
+++ b/dev-python/astroid/Manifest
@@ -1,2 +1,3 @@
DIST astroid-2.12.10.gh.tar.gz 435902 BLAKE2B eccabfbbda11edc958b0e5d5870f5df88cb267249d4d440e470515b75cda992ce9e7fd3dd50b9165ca40c6643053b0df0aeb754ec3b0461ea8a1ce45b0065ceb SHA512 55c3013a1672c4ce82f44ea85e4ac16881f0ea0a2f25b6457044e3c824699e13d46f5007f7410ca8d9a7d69c6690c8c41a187c9650fd4d4b7e9a7aa31e21add3
+DIST astroid-2.12.11.gh.tar.gz 436132 BLAKE2B ba3aa5766e669d1b509856cd8eb8cb90f6483b8459e6a2511945c4c54f28d86179b3420d6bfa26f54cf459926114d34dd2fe7d775f356eda17f995be860672a3 SHA512 1e8e364bcebce90d06f90494e2a029bfeae89a0dd3120400fa6ff5098ca05ec7c7f520336cc3b174ac007c81e272d774385c35f94762789b767d38e603c7d41d
DIST astroid-2.12.8.gh.tar.gz 434545 BLAKE2B 3ad3ff1a7e1a0c9433387b4167041adcc405e9b6d0fc0a850073960db9e7458d0b6989e3a0f78679ba4730f1da2fe9d35de3f984d2c79532d9f96c2a726b1f0e SHA512 76052caaef27f983751e3abfb44c38ad497a4d2d659521ee55c99080c9cacea90cf3603d6468b01cc9b127cd8318157faae56bb151c6449145c70545719c6c51
diff --git a/dev-python/astroid/astroid-2.12.11.ebuild b/dev-python/astroid/astroid-2.12.11.ebuild
new file mode 100644
index 000000000000..a7561581a64c
--- /dev/null
+++ b/dev-python/astroid/astroid-2.12.11.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Abstract Syntax Tree for logilab packages"
+HOMEPAGE="
+ https://github.com/PyCQA/astroid/
+ https://pypi.org/project/astroid/
+"
+SRC_URI="
+ https://github.com/PyCQA/astroid/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# Version specified in pyproject.toml
+RDEPEND="
+ >=dev-python/lazy-object-proxy-1.4.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-3.10[${PYTHON_USEDEP}]
+ <dev-python/wrapt-2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # no clue why it's broken
+ tests/unittest_modutils.py::GetModulePartTest::test_known_values_get_builtin_module_part
+ tests/unittest_brain_dataclasses.py::test_pydantic_field
+ tests/unittest_brain.py::SixBrainTest::test_from_imports
+ tests/unittest_regrtest.py::NonRegressionTests::test_numpy_distutils
+ # some problem with warnings (our options?)
+ tests/unittest_decorators.py::TestDeprecationDecorators::test_deprecated_default_argument_values_one_arg
+ tests/unittest_decorators.py::TestDeprecationDecorators::test_deprecated_default_argument_values_two_args
+ tests/unittest_scoped_nodes.py::test_deprecation_of_doc_attribute
+ )
+
+ # Faker causes sys.path_importer_cache keys to be overwritten
+ # with PosixPaths
+ epytest -p no:faker
+}