summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-01-06 20:31:33 -0500
committerMatt Turner <mattst88@gentoo.org>2021-01-06 21:12:25 -0500
commit913550796099bd712600cd5480f32aaed3db1b3d (patch)
tree5a26e6d0a0122303a529dc7a082e8a33d4578a47
parentx11-libs/vte: Version bump to 0.62.1 (diff)
downloadgentoo-91355079.tar.gz
gentoo-91355079.tar.bz2
gentoo-91355079.zip
x11-terms/gnome-terminal: Version bump to 3.38.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-terms/gnome-terminal/Manifest2
-rw-r--r--x11-terms/gnome-terminal/gnome-terminal-3.38.1.ebuild85
2 files changed, 87 insertions, 0 deletions
diff --git a/x11-terms/gnome-terminal/Manifest b/x11-terms/gnome-terminal/Manifest
index 16cea1cebad6..408d5919c105 100644
--- a/x11-terms/gnome-terminal/Manifest
+++ b/x11-terms/gnome-terminal/Manifest
@@ -1,2 +1,4 @@
DIST gnome-terminal-3.36.2-cntr-ntfy-autottl-ts.patch.xz 33900 BLAKE2B 51ad0305c4d822483f19cc92314beedc2f0aee23435ae9fe5337f1dd494c8749b27ee2329ec2d2aba055d03dbb65485bd5d740f5f43f9f252679aca6c83f0db1 SHA512 d595a8d6a2a8a54120cd87c33ec5b6b9540af51c1e280a25c9182d6410c6762a96f13a6c84ea2c61eb524681f4ab0853b41e6eabef637362647bf67e8709fb63
DIST gnome-terminal-3.36.2.tar.xz 2528492 BLAKE2B a303c5c9d053ef9f320dee84efa7fe47d47ed794ae14e4691603379da1b0f48161af8f80885917531af72fd402deaa8e8628a76419e4b780ee9871271731427d SHA512 0d691452456dd495b812332f206b6f8a590f67d47a6afce582b2ff0587747c36cb1eaf249080c6a3c3540ef22a50628801165d6c17eeb1b821eea1e244f79a91
+DIST gnome-terminal-3.38.1-cntr-ntfy-autottl-ts.patch.xz 33396 BLAKE2B a64a074d144cb43268e3b5ba3cdd4501663324a2a43649d1028deb64d493b57a3139dad1f627fb8655a6d7e16a1a111af7f0442b5f0b913b9f3b154084057f08 SHA512 f1d9b683ff58666a51b11807a48f3d5fde5715155610b5aeb897cd79943481acf54987d6af829c042f57ee1b17becfd76e5ba1ed06757fa99404d22ab9c196dd
+DIST gnome-terminal-3.38.1.tar.xz 2558708 BLAKE2B 5ae73123d4e53f6f4ffe83c2ad1d12bf0ac87ad5d62d7d28a55439e4e969985cd15d91aa6673a505b69f5d194aef2f8aa6346d41201262d39e4a196b48d69c19 SHA512 99d1e87a56dd5ce0c421f8b1ab197f25d8e878cbf1166786263cc9bf85b28eba327b0228a4ec35b8f656bdc3c5d7d48c5aca1768148fc5f324ff3f1c70983993
diff --git a/x11-terms/gnome-terminal/gnome-terminal-3.38.1.ebuild b/x11-terms/gnome-terminal/gnome-terminal-3.38.1.ebuild
new file mode 100644
index 000000000000..8c46f6311927
--- /dev/null
+++ b/x11-terms/gnome-terminal/gnome-terminal-3.38.1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome2 readme.gentoo-r1
+
+DESCRIPTION="The Gnome Terminal"
+HOMEPAGE="https://wiki.gnome.org/Apps/Terminal/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="debug +gnome-shell +nautilus vanilla"
+SRC_URI+=" !vanilla? ( https://dev.gentoo.org/~mattst88/distfiles/${P}-cntr-ntfy-autottl-ts.patch.xz )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+# FIXME: automagic dependency on gtk+[X], just transitive but needs proper control, bug 624960
+RDEPEND="
+ >=dev-libs/glib-2.52:2
+ >=x11-libs/gtk+-3.22.27:3
+ >=x11-libs/vte-0.62.1:2.91[!vanilla?]
+ >=dev-libs/libpcre2-10
+ >=gnome-base/dconf-0.14
+ >=gnome-base/gsettings-desktop-schemas-0.1.0
+ sys-apps/util-linux
+ gnome-shell? ( gnome-base/gnome-shell )
+ nautilus? ( >=gnome-base/nautilus-3.28.0 )
+"
+DEPEND="${RDEPEND}"
+# itstool required for help/* with non-en LINGUAS, see bug #549358
+# xmllint required for glib-compile-resources, see bug #549304
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DOC_CONTENTS="To get previous working directory inherited in new opened tab, or
+ notifications of long-running commands finishing, you will need
+ to add the following line to your ~/.bashrc:\n
+ . /etc/profile.d/vte-2.91.sh"
+
+src_prepare() {
+ if ! use vanilla; then
+ # https://bugzilla.gnome.org/show_bug.cgi?id=695371
+ # Fedora patches:
+ # Restore transparency support (with compositing WMs only)
+ # OSC 777 desktop notification support (notifications on tabs for long-running commands completing)
+ # Restore "Set title" support
+ # Automatic title updating based on currently running foreground process
+ # https://src.fedoraproject.org/rpms/gnome-terminal/raw/f31/f/gnome-terminal-cntr-ntfy-autottl-ts.patch
+ # Depends on vte[-vanilla] for OSC 777 and the preexec/precmd/etc patches in VTE
+ eapply "${WORKDIR}"/${P}-cntr-ntfy-autottl-ts.patch
+ fi
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable debug) \
+ $(use_enable gnome-shell search-provider) \
+ $(use_with nautilus nautilus-extension)
+}
+
+src_install() {
+ DOCS=( AUTHORS ChangeLog HACKING NEWS )
+ gnome2_src_install
+ if ! use vanilla; then
+ # Separate "New Window/Tab" menu entries by default, instead of unified "New Terminal"
+ insinto /usr/share/glib-2.0/schemas
+ newins "${FILESDIR}"/separate-new-tab-window.gschema.override org.gnome.Terminal.gschema.override
+ fi
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}