summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-15 08:36:39 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-15 08:37:07 +1300
commit914bdcba7885cb18e0195eb23faefd1544ee75ac (patch)
tree5aff50d1397cd1bbdaacf973c1b9d661e3aab54e
parentapp-admin/augeas: cleanup for bug 628084 CVE-2017-7555 (diff)
downloadgentoo-914bdcba.tar.gz
gentoo-914bdcba.tar.bz2
gentoo-914bdcba.zip
dev-perl/Apache2-AuthenNTLM: Fixup tests
- EAPI6 - Fix Description - Compile test all modules - Run test suite Package-Manager: Portage-2.3.8, Repoman-2.3.3
-rw-r--r--dev-perl/Apache2-AuthenNTLM/Apache2-AuthenNTLM-0.20.0-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-perl/Apache2-AuthenNTLM/Apache2-AuthenNTLM-0.20.0-r2.ebuild b/dev-perl/Apache2-AuthenNTLM/Apache2-AuthenNTLM-0.20.0-r2.ebuild
new file mode 100644
index 000000000000..3f376ef51fd5
--- /dev/null
+++ b/dev-perl/Apache2-AuthenNTLM/Apache2-AuthenNTLM-0.20.0-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=SPEEVES
+DIST_VERSION=0.02
+inherit perl-module
+
+DESCRIPTION="Perform Microsoft NTLM and Basic User Authentication"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="virtual/perl-MIME-Base64
+ >=www-apache/mod_perl-2"
+DEPEND="${RDEPEND}"
+
+src_test() {
+ local MODULES=(
+ "Apache2::AuthenNTLM ${DIST_VERSION}"
+ "Authen::Smb 0.96"
+ )
+ local failed=()
+ for dep in "${MODULES[@]}"; do
+ ebegin "Compile testing ${dep}"
+ perl -Mblib="${S}" -M"${dep} ()" -e1
+ eend $? || failed+=( "$dep" )
+ done
+ if [[ ${failed[@]} ]]; then
+ echo
+ eerror "One or more modules failed compile:";
+ for dep in "${failed[@]}"; do
+ eerror " ${dep}"
+ done
+ die "Failing due to module compilation errors";
+ fi
+ perl-module_src_test
+}