summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephan Hartmann <sultan@gentoo.org>2022-08-29 13:26:10 +0200
committerStephan Hartmann <sultan@gentoo.org>2022-08-29 22:15:28 +0200
commit91664da1598843b863eedcd633c728fa53740a6a (patch)
tree08bd1ede3bd1e541bf198b4cfd32c1590cdfc389
parentapp-shells/fzf: fix MY_GIT_REV (diff)
downloadgentoo-91664da1.tar.gz
gentoo-91664da1.tar.bz2
gentoo-91664da1.zip
net-libs/libsrtp: add 2.4.2
Move to meson build system. Closes: https://github.com/gentoo/gentoo/pull/27055 Signed-off-by: Stephan Hartmann <sultan@gentoo.org>
-rw-r--r--net-libs/libsrtp/Manifest1
-rw-r--r--net-libs/libsrtp/files/libsrtp-2.4.2-doc.patch42
-rw-r--r--net-libs/libsrtp/libsrtp-2.4.2.ebuild72
3 files changed, 115 insertions, 0 deletions
diff --git a/net-libs/libsrtp/Manifest b/net-libs/libsrtp/Manifest
index e077b2f0b4af..a4c4c10f5c91 100644
--- a/net-libs/libsrtp/Manifest
+++ b/net-libs/libsrtp/Manifest
@@ -1,2 +1,3 @@
DIST libsrtp-1.6.0.tar.gz 1648862 BLAKE2B 5526d7659db160df3b6d9f14922bd731d083f04c6dd084ef473c439d720733d0fd8b38bdfe92e30e05a8a94c41df965d04bca52601b2644352428b49b1ed9093 SHA512 5ac712d0d343c3b63ed248503cc7d33c637895a274c4434c91f513be117836f27cd5daba83088b4647bbd9c82d841e216e6346af8d485cb9ddcd35dee21d4887
DIST libsrtp-2.3.0.tar.gz 633819 BLAKE2B 9ea40e9689fabc29b7a2c637bd4e4a2c44eec79205a6e5c5e5abf1069dfec7ba28d868ba620462205d61fdb28d0ca3b8532c1f59db704edd508e01afb551d255 SHA512 34b1a01cb9a75aed175be09aadd2827224203b9801becc3fbc5214667cce79c3b87b0f59e4315583863ab5a2cc4fc81d56ab604a5e4c984518b8a8a2a7b77461
+DIST libsrtp-2.4.2.tar.gz 631393 BLAKE2B a062fb7a92294c66f1876c66bf05d9b11412a170c5f7221089680770ab85a62eabb68f781e487981b28602b1f4f7dbba07ebd44ed0248deaf6b9b56061227534 SHA512 6e4805e6d34b2050a6f68f629b0b42356b1d27f2cbaa6cc6166e56957609c3d9aa6b723dcc674e5c74180d122d27badd2f9496639ccb1e0c210b9e1f7949d0e2
diff --git a/net-libs/libsrtp/files/libsrtp-2.4.2-doc.patch b/net-libs/libsrtp/files/libsrtp-2.4.2-doc.patch
new file mode 100644
index 000000000000..571c3f3c5d44
--- /dev/null
+++ b/net-libs/libsrtp/files/libsrtp-2.4.2-doc.patch
@@ -0,0 +1,42 @@
+--- a/doc/Doxyfile.in
++++ b/doc/Doxyfile.in
+@@ -771,13 +771,13 @@ WARN_LOGFILE =
+ # spaces. See also FILE_PATTERNS and EXTENSION_MAPPING
+ # Note: If this tag is empty the current directory is searched.
+
+-INPUT = ../README.md \
+- ../include/srtp.h \
+- ../crypto/include/auth.h \
+- ../crypto/include/cipher.h \
+- ../crypto/include/crypto_types.h \
+- ../crypto/include/err.h \
+- crypto_kernel.txt
++INPUT = @TOP_SRCDIR@/README.md \
++ @TOP_SRCDIR@/include/srtp.h \
++ @TOP_SRCDIR@/crypto/include/auth.h \
++ @TOP_SRCDIR@/crypto/include/cipher.h \
++ @TOP_SRCDIR@/crypto/include/crypto_types.h \
++ @TOP_SRCDIR@/crypto/include/err.h \
++ @TOP_SRCDIR@/doc/crypto_kernel.txt
+
+ # This tag can be used to specify the character encoding of the source files
+ # that doxygen parses. Internally doxygen uses the UTF-8 encoding. Doxygen uses
+@@ -1104,7 +1104,7 @@ HTML_FOOTER =
+ # obsolete.
+ # This tag requires that the tag GENERATE_HTML is set to YES.
+
+-HTML_STYLESHEET = docs.css
++HTML_STYLESHEET = @TOP_SRCDIR@/doc/docs.css
+
+ # The HTML_EXTRA_STYLESHEET tag can be used to specify additional user-defined
+ # cascading style sheets that are included after the standard style sheets
+--- a/doc/meson.build
++++ b/doc/meson.build
+@@ -8,6 +8,7 @@ endif
+
+ doc_config = configuration_data()
+ doc_config.set('LIBSRTPVERSIONNUMBER', meson.project_version())
++doc_config.set('TOP_SRCDIR', meson.source_root())
+
+ doxyfile = configure_file(input: 'Doxyfile.in',
+ output: 'Doxyfile',
diff --git a/net-libs/libsrtp/libsrtp-2.4.2.ebuild b/net-libs/libsrtp/libsrtp-2.4.2.ebuild
new file mode 100644
index 000000000000..593b1ed935be
--- /dev/null
+++ b/net-libs/libsrtp/libsrtp-2.4.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson-multilib
+
+DESCRIPTION="Open-source implementation of the Secure Real-time Transport Protocol (SRTP)"
+HOMEPAGE="https://github.com/cisco/libsrtp"
+SRC_URI="https://github.com/cisco/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="2/1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv -sparc ~x86 ~ppc-macos ~x64-macos"
+IUSE="debug doc nss openssl static-libs test"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="?? ( nss openssl )"
+
+RDEPEND="
+ openssl? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )
+ nss? ( >=dev-libs/nss-3.52[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig
+"
+
+PATCHES=( "${FILESDIR}"/libsrtp-2.4.2-doc.patch )
+
+multilib_src_configure() {
+ local crypto_lib="none"
+ use openssl && crypto_lib="openssl"
+ use nss && crypto_lib="nss"
+
+ # stdout: default error output for messages in debug
+ # openssl-kdf: OpenSSL 1.1.0+
+ local emesonargs=(
+ -Dcrypto-library=${crypto_lib}
+ -Dcrypto-library-kdf=disabled
+ -Dfuzzer=disabled
+ -Dlog-stdout=true
+ -Dpcap-tests=disabled
+ -Ddefault_library=$(usex static-libs both shared)
+
+ $(meson_feature test tests)
+ $(meson_native_use_feature doc)
+ $(meson_use debug debug-logging)
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+ if multilib_is_native_abi && use doc; then
+ meson_src_compile doc
+ fi
+}
+
+multilib_src_install() {
+ if multilib_is_native_abi && use doc; then
+ dodoc -r html
+ fi
+ meson_src_install
+}
+
+multilib_src_install_all() {
+ local DOCS=( CHANGES )
+ einstalldocs
+}