summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Eisele <kernlpanic@dennis-eisele.de>2022-02-22 01:09:05 +0100
committerSam James <sam@gentoo.org>2022-02-22 01:40:19 +0000
commit916d5d52de676833b5006e68a5d00b3dccb1f8c0 (patch)
treef5c4b01c155d7326ddf54842abc4e216bb7bf6c9
parentdev-lang/ocaml: drop 4.05.0-r7, 4.05.0-r8, 4.10.2-r2 (diff)
downloadgentoo-916d5d52de676833b5006e68a5d00b3dccb1f8c0.tar.gz
gentoo-916d5d52de676833b5006e68a5d00b3dccb1f8c0.tar.bz2
gentoo-916d5d52de676833b5006e68a5d00b3dccb1f8c0.zip
net-misc/unison: bump version to 2.51.5 and bump EAPI to 8
Closes: https://bugs.gentoo.org/818247 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Dennis Eisele <kernlpanic@dennis-eisele.de> Closes: https://github.com/gentoo/gentoo/pull/24294 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-misc/unison/Manifest1
-rw-r--r--net-misc/unison/unison-2.51.5.ebuild105
2 files changed, 106 insertions, 0 deletions
diff --git a/net-misc/unison/Manifest b/net-misc/unison/Manifest
index 0e186b02e774..e20b41c58602 100644
--- a/net-misc/unison/Manifest
+++ b/net-misc/unison/Manifest
@@ -1,2 +1,3 @@
DIST unison-2.51.3_p20201127.tar.gz 1374770 BLAKE2B 83c133f2cb99e10fac96efde333291a671edab5eb45dd6dcf56cb25845385425353a5f413ab752361124ec7bbac21daf3f813d5539b21229d943cf7f0bfae2fd SHA512 4b978a5e3df620317b7a9214054d64f319d09c5617b07ddf3cf76b18c6888841ce791f7b6a4ef70c64b146e3e4f25a5904584fb576703c2de4b17cfcffa8905a
DIST unison-2.51.4_rc2.tar.gz 1377263 BLAKE2B d403e019f0757f66be5157cff97596c9dae1306a5ba33af27fe55a69fb1ae50d6ef6db54403d14a0afb27cb7a0ebe198021d6cdf58430c530575fc934c837703 SHA512 c61f827490036fbe3074ce5d970e6b4e981a4fde848c307c817f51d73f450d4b5d437503f5392bd2b654121547919b9724112383f71736a9e0e7b308bc3e99b6
+DIST unison-2.51.5.tar.gz 1385407 BLAKE2B cdad4683518ec9c7c43d9107d8533fa393a68f602782d96ddba345df07b1ef70cc2ebf7dfd205fc7535349553a5e0d3c2931099bde99e5c736bc815ccdd294f8 SHA512 4a31df4d043d2b7552438f9fc2056098b9a35cd1cae1a037083cb56d91ec6fec0c3164de73914ff46cb8821f78c1594f48bf0334a94d9d706cd82ce3a6b70440
diff --git a/net-misc/unison/unison-2.51.5.ebuild b/net-misc/unison/unison-2.51.5.ebuild
new file mode 100644
index 000000000000..9e1573deb3a6
--- /dev/null
+++ b/net-misc/unison/unison-2.51.5.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop xdg-utils
+
+DESCRIPTION="Two-way cross-platform file synchronizer"
+HOMEPAGE="https://www.seas.upenn.edu/~bcpierce/unison/"
+SRC_URI="https://github.com/bcpierce00/unison/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+IUSE="debug doc gtk +ocamlopt threads"
+
+# ocaml version so we are sure it has ocamlopt use flag
+BDEPEND="dev-lang/ocaml:=[ocamlopt?]
+ doc? ( app-text/dvipsk
+ app-text/ghostscript-gpl
+ dev-texlive/texlive-latex )"
+DEPEND="gtk? ( dev-ml/lablgtk:2=[ocamlopt?] )"
+RDEPEND="gtk? ( dev-ml/lablgtk:2=[ocamlopt?]
+ || ( net-misc/x11-ssh-askpass net-misc/ssh-askpass-fullscreen ) )
+ >=app-eselect/eselect-unison-0.4"
+
+DOCS=( CONTRIB INSTALL NEWS README ROADMAP.txt TODO.txt )
+
+src_prepare() {
+ default
+ # https://github.com/bcpierce00/unison/issues/416
+ sed -e "/ifdef\ HEVEA/,/endif/d" -i doc/Makefile || die
+ # https://github.com/bcpierce00/unison/pull/415
+ sed -e "/myName/d" -i doc/docs.ml || die
+}
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ myconf+=( THREADS=true )
+ fi
+
+ if use debug; then
+ myconf+=( DEBUGGING=true )
+ fi
+
+ if use gtk; then
+ myconf+=( UISTYLE=gtk2 )
+ else
+ myconf+=( UISTYLE=text )
+ fi
+
+ use ocamlopt || myconf+=( NATIVE=false )
+
+ if use doc; then
+ VARTEXFONTS="${T}/fonts" emake "${myconf[@]}" CFLAGS="" HEVEA=false docs
+ fi
+
+ # Discard cflags as it will try to pass them to ocamlc...
+ emake "${myconf[@]}" CFLAGS="" src
+}
+
+src_test() {
+ emake test CFLAGS=""
+}
+
+src_install() {
+ # install manually, since it's just too much
+ # work to force the Makefile to do the right thing.
+ local binname
+ cd src || die
+ for binname in unison unison-fsmonitor; do
+ newbin ${binname} ${binname}-${SLOT}
+ done
+
+ if use gtk; then
+ newicon -s scalable ../icons/U.svg ${PN}-${SLOT}.svg
+ make_desktop_entry ${PN}-${SLOT} "${PN} (${SLOT})" "${PN}-${SLOT}"
+ fi
+
+ if use doc; then
+ DOCS+=( ../doc/unison-manual.pdf )
+ HTML_DOCS=( "${DISTDIR}/${P}-manual.html" )
+ fi
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "Unison now uses SLOTs, so you can specify servercmd=/usr/bin/unison-${SLOT}"
+ elog "in your profile files to access exactly this version over ssh."
+ elog "Or you can use 'eselect unison' to set the version."
+ eselect unison update || die
+
+ if use gtk; then
+ xdg_icon_cache_update
+ fi
+}
+
+pkg_postrm() {
+ if use gtk; then
+ xdg_icon_cache_update
+ fi
+}