summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-02 10:18:43 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-02 10:26:56 +0100
commit9170bba7020993928fb8cf38dc45ec9de0e6d924 (patch)
tree3ba8ff504e788fbcc1fdef611ced4dd877380044
parentsys-kernel/gentoo-kernel-bin: Bump to 5.16.5 (diff)
downloadgentoo-9170bba7.tar.gz
gentoo-9170bba7.tar.bz2
gentoo-9170bba7.zip
dev-python/tomlkit: Force setuptools build to fix poetry dep cycle
Closes: https://bugs.gentoo.org/832531 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/tomlkit/tomlkit-0.9.0-r1.ebuild (renamed from dev-python/tomlkit/tomlkit-0.9.0.ebuild)11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-python/tomlkit/tomlkit-0.9.0.ebuild b/dev-python/tomlkit/tomlkit-0.9.0-r1.ebuild
index 7ec87f0790cf..4de45e362c79 100644
--- a/dev-python/tomlkit/tomlkit-0.9.0.ebuild
+++ b/dev-python/tomlkit/tomlkit-0.9.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-DISTUTILS_USE_PEP517=poetry
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( pypy3 python3_{8..10} )
inherit distutils-r1
@@ -19,3 +19,12 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~
BDEPEND="test? ( dev-python/pyyaml[${PYTHON_USEDEP}] )"
distutils_enable_tests pytest
+
+src_configure() {
+ # use setup.py to avoid circular dep with poetry-core
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["setuptools", "wheel"]
+ build-backend = "setuptools.build_meta"
+ EOF
+}