summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-03-31 23:38:11 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-04-01 23:53:29 +0200
commit917f5fbf453e189c7a6085dae3094670aa3a138e (patch)
treecca2c5e985472c811cec0c713574557dcdb66a73
parentdev-python/lesscpy: version bump. (diff)
downloadgentoo-917f5fbf.tar.gz
gentoo-917f5fbf.tar.bz2
gentoo-917f5fbf.zip
dev-python/markdown: version bump.
Closes: https://bugs.gentoo.org/636872 Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--dev-python/markdown/Manifest1
-rw-r--r--dev-python/markdown/markdown-2.6.9.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/markdown/Manifest b/dev-python/markdown/Manifest
index a966acaeeda0..a2e10943bf93 100644
--- a/dev-python/markdown/Manifest
+++ b/dev-python/markdown/Manifest
@@ -1,2 +1,3 @@
DIST Markdown-2.6.5.tar.gz 301781 BLAKE2B 527a84bc8c4a891e64749bce273bf10c439376386c27355f386de8a0dd89e2bf0c1d6cadb0ff937fa3825655ab6220901f7b17ea2d184f3b3d178cbb54af58b8 SHA512 d966136a7184ada4eec70af661aba441694a8c4f59e57d59a28dfbc1649ca1e90cc1e4a29b354b3caf35362e1e0c96eeb3f46c68f82d7a898b76c08866d459d3
DIST Markdown-2.6.8.tar.gz 307330 BLAKE2B 6867f15425bd84bc030ab52000dc2f83bff0c9885854cec4a2a785f80b18129160bc57da30226fe17f42043b4938482e2e4eff9cdb3d4370b0146cc09f1ff576 SHA512 85c1a16ebb50af79f378eb2fa936342df6174a4f597a74fee6d0495ef2bc4c7c8337463799e427cb6788b3429e400309958b5c4784f536593047ab2e47ac7c23
+DIST Markdown-2.6.9.tar.gz 271564 BLAKE2B 792e438955a55de9f473107618516d17129caa4d02097d510992d25715a4f28aae005781b3a2e4fe53692bc12e96ab49008b66ff49247bf1685bac4c7607e0b6 SHA512 d00c800dc7c1ae0753cbcddd755ade7d593a8d9c9d4ffc6eb8765233a44027a75b68948c14b4469d7aa0e7f74029e9f60159d81ed40b3d2e770c68a81533ccfa
diff --git a/dev-python/markdown/markdown-2.6.9.ebuild b/dev-python/markdown/markdown-2.6.9.ebuild
new file mode 100644
index 000000000000..f30420fc6e3c
--- /dev/null
+++ b/dev-python/markdown/markdown-2.6.9.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the markdown markup language"
+HOMEPAGE="
+ http://www.freewisdom.org/projects/python-markdown
+ https://pypi.python.org/pypi/Markdown
+ https://pythonhosted.org/Markdown/
+ https://github.com/waylan/Python-Markdown"
+SRC_URI="mirror://pypi/M/${PN^}/${P^}.tar.gz"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc test pygments"
+
+DEPEND="
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pytidylib[${PYTHON_USEDEP}]
+ )"
+# source cites pytidylib however from testruns it appears optional
+RDEPEND="pygments? ( dev-python/pygments[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${P^}"
+
+PATCHES=(
+ # build system always builds docs
+ "${FILESDIR}"/${PN}-2.6.8-dont-build-docs-default.patch
+)
+
+python_compile_all() {
+ if use doc; then
+ esetup.py build_docs
+ HTML_DOCS=( "${BUILD_DIR}"/docs/. )
+
+ # remove .txt files
+ find "${BUILD_DIR}"/docs -name '*.txt' -delete || die
+ fi
+}
+
+python_test() {
+ cp -r -l run-tests.py tests "${BUILD_DIR}"/ || die
+ cd "${BUILD_DIR}" || die
+ "${EPYTHON}" run-tests.py || die "Tests fail with ${EPYTHON}"
+}