summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-09-28 23:15:27 +0300
committerMart Raudsepp <leio@gentoo.org>2019-09-28 23:15:27 +0300
commit9198c24e859e9d7a1612d7ea0ddf3d0f71f9486e (patch)
tree755d82fd146e638491410b4db12f8ba4b259a0be
parentx11-themes/gnome-backgrounds: bump to 3.32.0 (diff)
downloadgentoo-9198c24e.tar.gz
gentoo-9198c24e.tar.bz2
gentoo-9198c24e.zip
gnome-base/gnome-light: bump to 3.32.2
Package-Manager: Portage-2.3.69, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
-rw-r--r--gnome-base/gnome-light/gnome-light-3.32.2.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/gnome-base/gnome-light/gnome-light-3.32.2.ebuild b/gnome-base/gnome-light/gnome-light-3.32.2.ebuild
new file mode 100644
index 000000000000..48fe1d876ddf
--- /dev/null
+++ b/gnome-base/gnome-light/gnome-light-3.32.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eapi7-ver
+
+P_RELEASE="$(ver_cut 1-2)"
+
+DESCRIPTION="Meta package for GNOME-Light, merge this package to install"
+HOMEPAGE="https://www.gnome.org/"
+LICENSE="metapackage"
+SLOT="2.0"
+IUSE="cups +gnome-shell"
+
+# when unmasking for an arch
+# double check none of the deps are still masked !
+KEYWORDS="~amd64 ~x86"
+
+# XXX: Note to developers:
+# This is a wrapper for the 'light' GNOME 3 desktop, and should only consist of
+# the bare minimum of libs/apps needed. It is basically gnome-base/gnome without
+# any apps, but shouldn't be used by users unless they know what they are doing.
+# cantarell minimum version is ensured here as gnome-shell depends on it.
+RDEPEND="
+ >=gnome-base/gnome-core-libs-${PV}[cups?]
+
+ >=gnome-base/gnome-session-3.32.0
+ >=gnome-base/gnome-settings-daemon-3.32.0[cups?]
+ >=gnome-base/gnome-control-center-${PV}[cups?]
+
+ >=gnome-base/nautilus-${PV}
+
+ gnome-shell? (
+ >=x11-wm/mutter-${PV}
+ >=dev-libs/gjs-1.56.2
+ >=gnome-base/gnome-shell-${PV}
+ >=media-fonts/cantarell-0.111 )
+
+ >=x11-themes/adwaita-icon-theme-${P_RELEASE}
+ >=x11-themes/gnome-themes-standard-3.28
+ >=x11-themes/gnome-backgrounds-${P_RELEASE}
+
+ >=x11-terms/gnome-terminal-${PV}
+"
+DEPEND=""
+PDEPEND=">=gnome-base/gvfs-1.40.1"
+S="${WORKDIR}"
+
+pkg_pretend() {
+ if ! use gnome-shell; then
+ # Users probably want to use gnome-flashback, e16, sawfish, etc
+ ewarn "You're not installing GNOME Shell"
+ ewarn "You will have to install and manage a window manager by yourself"
+ fi
+}
+
+pkg_postinst() {
+ # Remember people where to find our project information
+ elog "Please remember to look at https://wiki.gentoo.org/wiki/Project:GNOME"
+ elog "for information about the project and documentation."
+}