summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-18 01:48:16 +0000
committerSam James <sam@gentoo.org>2021-11-18 01:48:16 +0000
commit9199df6a942fbdf85056b129060a7aaf996fb27c (patch)
tree91b3f0bd677cf67e5f31e3f5d4a4fcacd5bdd737
parentapp-admin/vault: Bump to version 1.9.0 (diff)
downloadgentoo-9199df6a942fbdf85056b129060a7aaf996fb27c.tar.gz
gentoo-9199df6a942fbdf85056b129060a7aaf996fb27c.tar.bz2
gentoo-9199df6a942fbdf85056b129060a7aaf996fb27c.zip
sci-geosciences/opencpn-plugin-br24radar: [QA] Revert "drop package"
This reverts commit c75de59244059821a549f7ebfd4f0691ba09cd1b. Caused a tree breakage because opencpn-plugins-meta still depends on it. I couldn't spot a last-rite email/mask for this package either, so it seems best to just restore it for now, and handle removal normally (last-rites if they weren't sent + revbumping the meta). Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sci-geosciences/opencpn-plugin-br24radar/Manifest1
-rw-r--r--sci-geosciences/opencpn-plugin-br24radar/metadata.xml15
-rw-r--r--sci-geosciences/opencpn-plugin-br24radar/opencpn-plugin-br24radar-2.1.ebuild35
-rw-r--r--sci-geosciences/opencpn-plugin-br24radar/opencpn-plugin-br24radar-9999.ebuild35
4 files changed, 86 insertions, 0 deletions
diff --git a/sci-geosciences/opencpn-plugin-br24radar/Manifest b/sci-geosciences/opencpn-plugin-br24radar/Manifest
new file mode 100644
index 000000000000..ba6a4a5e43d3
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-br24radar/Manifest
@@ -0,0 +1 @@
+DIST opencpn-plugin-br24radar-2.1.tar.gz 3947426 BLAKE2B a850973caa64ba4855d97e9374a5e40e292fd0df47a783a711453c49a07f3d945e33247a6199c5c1378dcc1ae29c2e4707675a12b02d3abbd8a115eaf107470c SHA512 357553396fd020e192dbbd5a05af1cd9e06c99244b426239a1d0aac4688affc1702bc16b62010236fc3af1ec7356f1dfb49e3afe3a94cb4dd7b1e0a2ef007af3
diff --git a/sci-geosciences/opencpn-plugin-br24radar/metadata.xml b/sci-geosciences/opencpn-plugin-br24radar/metadata.xml
new file mode 100644
index 000000000000..f3804ddd191b
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-br24radar/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mschiff@gentoo.org</email>
+ <name>Marc Schiffbauer</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-geosciences@gentoo.org</email>
+ <name>Gentoo Geosciences Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">canboat/BR24radar_pi</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-geosciences/opencpn-plugin-br24radar/opencpn-plugin-br24radar-2.1.ebuild b/sci-geosciences/opencpn-plugin-br24radar/opencpn-plugin-br24radar-2.1.ebuild
new file mode 100644
index 000000000000..72253384403b
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-br24radar/opencpn-plugin-br24radar-2.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+WX_GTK_VER="3.0"
+inherit cmake wxwidgets
+
+MY_PN="BR24radar_pi"
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/canboat/${MY_PN}.git"
+else
+ SRC_URI="https://github.com/canboat/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="Navico (Simrad, Lowrance) Broadband BR24/3G/4G Radar Plugin for OpenCPN"
+HOMEPAGE="https://github.com/canboat/BR24radar_pi"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}
+ >=sci-geosciences/opencpn-4.2.0"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/gettext"
+
+src_configure() {
+ setup-wxwidgets unicode
+ cmake_src_configure
+}
diff --git a/sci-geosciences/opencpn-plugin-br24radar/opencpn-plugin-br24radar-9999.ebuild b/sci-geosciences/opencpn-plugin-br24radar/opencpn-plugin-br24radar-9999.ebuild
new file mode 100644
index 000000000000..72253384403b
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-br24radar/opencpn-plugin-br24radar-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+WX_GTK_VER="3.0"
+inherit cmake wxwidgets
+
+MY_PN="BR24radar_pi"
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/canboat/${MY_PN}.git"
+else
+ SRC_URI="https://github.com/canboat/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="Navico (Simrad, Lowrance) Broadband BR24/3G/4G Radar Plugin for OpenCPN"
+HOMEPAGE="https://github.com/canboat/BR24radar_pi"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}
+ >=sci-geosciences/opencpn-4.2.0"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/gettext"
+
+src_configure() {
+ setup-wxwidgets unicode
+ cmake_src_configure
+}